Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-ezynq
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-ezynq
Commits
dd185f86
Commit
dd185f86
authored
Jan 21, 2016
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
append to deploy
parent
edc8afcc
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
19 additions
and
2 deletions
+19
-2
u-boot-ezynq-tasks.inc
recipes-bsp/u-boot/u-boot-ezynq-tasks.inc
+17
-2
u-boot-ezynq_2016.01.bb
recipes-bsp/u-boot/u-boot-ezynq_2016.01.bb
+2
-0
No files found.
recipes-bsp/u-boot/u-boot-ezynq-tasks.inc
View file @
dd185f86
...
@@ -99,7 +99,9 @@ do_compile(){
...
@@ -99,7 +99,9 @@ do_compile(){
echo
"Other files are already created, repeating it here just to remind their paths"
echo
"Other files are already created, repeating it here just to remind their paths"
if
[
$
(
cat
.
config
|
grep
"CONFIG_SPL=y"
)
];
then
if
[
$
(
cat
.
config
|
grep
"CONFIG_SPL_OF_CONTROL=y"
)
];
then
UBOOT_FILE
=
"spl/u-boot-spl-dtb.bin"
elif
[
$
(
cat
.
config
|
grep
"CONFIG_SPL=y"
)
];
then
UBOOT_FILE
=
"spl/u-boot-spl.bin"
UBOOT_FILE
=
"spl/u-boot-spl.bin"
else
else
UBOOT_FILE
=
"u-boot.bin"
UBOOT_FILE
=
"u-boot.bin"
...
@@ -112,4 +114,17 @@ do_compile(){
...
@@ -112,4 +114,17 @@ do_compile(){
cd
$
{
WORKDIR
}
cd
$
{
WORKDIR
}
}
}
##########################################################################################
##########################################################################################
\ No newline at end of file
# do_deploy_append
do_deploy_append
()
{
if
[
$
(
cat
$
{
S
}
/.
config
|
grep
"CONFIG_OF_CONTROL=y"
)
];
then
rm
-
f
$
{
DEPLOYDIR
}
/
$
{
UBOOT_BINARY
}
install
$
{
S
}
/
u
-
boot
-
dtb
.
img
$
{
DEPLOYDIR
}
/
$
{
UBOOT_IMAGE
}
cd
$
{
DEPLOYDIR
}
rm
-
f
$
{
UBOOT_BINARY
}
$
{
UBOOT_SYMLINK
}
u
-
boot
-
dtb
.
img
ln
-
sf
$
{
UBOOT_IMAGE
}
$
{
UBOOT_SYMLINK
}
ln
-
sf
$
{
UBOOT_IMAGE
}
u
-
boot
-
dtb
.
img
fi
}
recipes-bsp/u-boot/u-boot-ezynq_2016.01.bb
View file @
dd185f86
...
@@ -12,3 +12,5 @@ include u-boot-ezynq.inc
...
@@ -12,3 +12,5 @@ include u-boot-ezynq.inc
PROVIDES = "u-boot virtual/bootloader"
PROVIDES = "u-boot virtual/bootloader"
inherit zynq7-platform-paths
inherit zynq7-platform-paths
#UBOOT_CONFIG="dtb"
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment