Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-ezynq
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-ezynq
Commits
69dc07b2
Commit
69dc07b2
authored
Mar 07, 2014
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
updated to the latest ezynq
parent
185d5225
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
26 additions
and
11 deletions
+26
-11
u-boot-ezynq-tasks.inc
recipes-bsp/u-boot/u-boot-ezynq-tasks.inc
+10
-4
u-boot-ezynq.inc
recipes-bsp/u-boot/u-boot-ezynq.inc
+15
-6
u-boot-ezynq_2013.01.bb
recipes-bsp/u-boot/u-boot-ezynq_2013.01.bb
+1
-1
No files found.
recipes-bsp/u-boot/u-boot-ezynq-tasks.inc
View file @
69dc07b2
...
...
@@ -86,7 +86,7 @@ do_compile(){
echo
"Compiling..."
cd
$
{
GITDIR_uboot
}
echo
"Running ezynqcfg.py for the first time - u-boot
.bin
length is not known yet, generating arch/arm/cpu/armv7/zynq/ezynq.c"
echo
"Running ezynqcfg.py for the first time - u-boot length is not known yet, generating arch/arm/cpu/armv7/zynq/ezynq.c"
$
{
GITDIR_ezynq_label
}
/
ezynqcfg
.
py
-
c
include
/
autoconf
.
mk
--
html
u
-
boot
.
html
-
o
boot_head
.
bin
--
html
-
mask
0x3ff
--
lowlevel
arch
/
arm
/
cpu
/
armv7
/
zynq
/
ezynq
.
c
...
...
@@ -95,13 +95,19 @@ do_compile(){
unset
CPPFLAGS
oe_runmake
echo
"Running ezynqcfg.py for the second time - u-boot
.bin
length is known and will be used in the RBL header"
echo
"Running ezynqcfg.py for the second time - u-boot length is known and will be used in the RBL header"
echo
"Other files are already created, repeating it here just to remind their paths"
$
{
GITDIR_ezynq_label
}
/
ezynqcfg
.
py
-
c
include
/
autoconf
.
mk
-
o
boot_head
.
bin
--
uboot
u
-
boot
.
bin
--
html
u
-
boot
.
html
--
html
-
mask
0x3ff
--
lowlevel
arch
/
arm
/
cpu
/
armv7
/
zynq
/
ezynq
.
c
if
[
$
(
cat
include
/
autoconf
.
mk
|
grep
"CONFIG_SPL=y"
)
];
then
UBOOT_FILE
=
"spl/u-boot-spl.bin"
else
UBOOT_FILE
=
"u-boot.bin"
fi
$
{
GITDIR_ezynq_label
}
/
ezynqcfg
.
py
-
c
include
/
autoconf
.
mk
-
o
boot_head
.
bin
--
uboot
$UBOOT_FILE
--
html
u
-
boot
.
html
--
html
-
mask
0x3ff
--
lowlevel
arch
/
arm
/
cpu
/
armv7
/
zynq
/
ezynq
.
c
cat
boot_head
.
bin
u
-
boot
.
bin
>
boot
.
bin
cat
boot_head
.
bin
$UBOOT_FILE
>
boot
.
bin
cd
$
{
WORKDIR
}
}
...
...
recipes-bsp/u-boot/u-boot-ezynq.inc
View file @
69dc07b2
require
recipes
-
bsp
/
u
-
boot
/
u
-
boot
.
inc
LICENSE
=
"GPLv2+ & GPLv3"
LIC_FILES_CHKSUM
=
"file://${GITDIR_uboot}/
COPYING;md5=1707d6db1d42237583f50183a5651ecb
\
LIC_FILES_CHKSUM
=
"file://${GITDIR_uboot}/
README;md5=8872462bd018b07588642610ee65380e
\
file://${GITDIR_ezynq}/LICENSE;md5=891e49b3c2a8c133ffe7985e54245aff"
# working directory
...
...
@@ -15,12 +15,17 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
# UBOOT_MACHINE is defined in meta-<board>/conf/machine/<board>.conf
# (e.g., meta-microzed/conf/machine/microzed.conf: UBOOT_MACHINE= zynq_microzed_config)
UBOOT_SUFFIX
=
"
bin
"
UBOOT_IMAGE
=
"boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_BINARY
=
"boot.${UBOOT_SUFFIX}"
UBOOT_SYMLINK
=
"boot-${MACHINE}.${UBOOT_SUFFIX}"
UBOOT_SUFFIX
=
"
img
"
UBOOT_IMAGE
=
"
u-
boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_BINARY
=
"
u-
boot.${UBOOT_SUFFIX}"
UBOOT_SYMLINK
=
"
u-
boot-${MACHINE}.${UBOOT_SUFFIX}"
UBOOT_MAKE_TARGET
=
"all"
SPL_SUFFIX
=
"bin"
SPL_BINARY
=
"boot.${SPL_SUFFIX}"
SPL_IMAGE
=
"boot-${MACHINE}-${PV}-${PR}.${SPL_SUFFIX}"
SPL_SYMLINK
=
"boot-${MACHINE}.${SPL_SUFFIX}"
##########################################################################################
# Variables used in the below overridden functions
GITDIR_ezynq_dir
=
"git"
...
...
@@ -38,7 +43,11 @@ SRC_URI_uboot= "git://github.com/Xilinx/u-boot-xlnx.git"
SRC_URI_uboot_branch
=
"master-next"
#SRCREV_ezynq= "83340698f9669977b7205aa67e6ca0dd23fb741f"
SRCREV_uboot
=
"bbd91fc9ae290c31dc52fd8322f43f67ddd39247"
SRCREV_ezynq
=
"89bb3ac2ed47ae48460e4dd82829d765b7922269"
#SRCREV_uboot= "bbd91fc9ae290c31dc52fd8322f43f67ddd39247"
#SRCREV_uboot= "6742f65365086ded52fa9726c9120de8a6ad541b"
SRCREV_uboot
=
"54fee227ef141214141a226efd17ae0516deaf32"
PATCH_NAME
=
"ezynq.patch"
...
...
recipes-bsp/u-boot/u-boot-ezynq_2013.01.bb
View file @
69dc07b2
...
...
@@ -3,7 +3,7 @@ HOMEPAGE = "http://elphel.com;http://blog.elphel.com"
SECTION = "bootloaders"
#Project Version
PV = "v201
3.01
"
PV = "v201
4.03
"
#Project Revision
PR = "r0"
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment