Commit b20b0e79 authored by Andrey Filippov's avatar Andrey Filippov

added configuartion for standard i2c chips

parent 2c1cd93e
......@@ -276,7 +276,7 @@ CONFIG_ARCH_MULTI_V6_V7=y
# CONFIG_ARCH_MULTI_CPU_AUTO is not set
# CONFIG_ARCH_MVEBU is not set
# CONFIG_ARCH_BCM is not set
# CONFIG_GPIO_PCA953X is not set
CONFIG_GPIO_PCA953X=y
# CONFIG_KEYBOARD_GPIO_POLLED is not set
# CONFIG_ARCH_HIGHBANK is not set
# CONFIG_ARCH_MXC is not set
......@@ -1552,7 +1552,7 @@ CONFIG_HWMON=y
# CONFIG_SENSORS_GPIO_FAN is not set
# CONFIG_SENSORS_HIH6130 is not set
# CONFIG_SENSORS_IT87 is not set
# CONFIG_SENSORS_JC42 is not set
CONFIG_SENSORS_JC42=y
# CONFIG_SENSORS_LINEAGE is not set
# CONFIG_SENSORS_LM63 is not set
# CONFIG_SENSORS_LM70 is not set
......
......@@ -184,6 +184,25 @@
0x20a0f0 /* just for testing: write data 0xa0 with write enable mask 0xf0 to register 0x020 */
>;
};
gpio@20{
compatible = "ti,tca6408";
reg = <0x20>;
};
gpio@21{
compatible = "ti,tca6408";
reg = <0x21>;
};
/* Use 'spd' instead of '24c02' for read only access*/
stts2002@31 {
compatible = "at,24c02";
reg = <0x31>;
};
hwmon@19 { /*hwmon@19*/
compatible = "stm,jc42";
reg = <0x19>;
};
} ;
ps7_gpio_0: ps7-gpio@e000a000 {
......
Index: git/drivers/misc/Kconfig
===================================================================
--- git.orig/drivers/misc/Kconfig 2013-11-29 17:23:40.563426999 -0700
+++ git/drivers/misc/Kconfig 2013-11-29 17:23:44.899427043 -0700
--- git.orig/drivers/misc/Kconfig 2013-11-29 23:33:09.275656939 -0700
+++ git/drivers/misc/Kconfig 2013-11-29 23:33:12.155656969 -0700
@@ -549,6 +549,19 @@
their requirements.
......@@ -24,8 +24,8 @@ Index: git/drivers/misc/Kconfig
source "drivers/misc/eeprom/Kconfig"
Index: git/drivers/misc/Makefile
===================================================================
--- git.orig/drivers/misc/Makefile 2013-11-29 17:23:40.563426999 -0700
+++ git/drivers/misc/Makefile 2013-11-29 17:23:44.899427043 -0700
--- git.orig/drivers/misc/Makefile 2013-11-29 23:33:09.275656939 -0700
+++ git/drivers/misc/Makefile 2013-11-29 23:33:12.155656969 -0700
@@ -55,3 +55,5 @@
obj-$(CONFIG_LATTICE_ECP3_CONFIG) += lattice-ecp3-config.o
obj-$(CONFIG_SRAM) += sram.o
......@@ -35,7 +35,7 @@ Index: git/drivers/misc/Makefile
Index: git/drivers/misc/vsc330x.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ git/drivers/misc/vsc330x.c 2013-11-29 17:23:44.899427043 -0700
+++ git/drivers/misc/vsc330x.c 2013-11-29 23:33:12.155656969 -0700
@@ -0,0 +1,872 @@
+/*!***************************************************************************
+ *! FILE NAME : vsc330x.c
......@@ -912,7 +912,7 @@ Index: git/drivers/misc/vsc330x.c
Index: git/drivers/misc/si5338.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ git/drivers/misc/si5338.c 2013-11-29 18:25:55.975465743 -0700
+++ git/drivers/misc/si5338.c 2013-11-29 23:33:12.159656969 -0700
@@ -0,0 +1,381 @@
+/*!***************************************************************************
+ *! FILE NAME : si5338.c
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment