Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
9097cfba
Commit
9097cfba
authored
Jul 27, 2016
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
preparing for Yocto 2.1 upgrade
parent
7e4fcd31
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
with
29 additions
and
19 deletions
+29
-19
linux-xlnx_4.0.bbappend
recipes-kernel/linux/linux-xlnx_4.0.bbappend
+29
-19
No files found.
recipes-kernel/linux/linux-xlnx_4.0.bbappend
View file @
9097cfba
...
@@ -33,40 +33,50 @@ INITRAMFS_IMAGE_BUNDLE = "1"
...
@@ -33,40 +33,50 @@ INITRAMFS_IMAGE_BUNDLE = "1"
#IMAGE_FSTYPES = "cpio.gz"
#IMAGE_FSTYPES = "cpio.gz"
do_fetch_append() {
do_fetch_append() {
if os.path.isdir("${DEV_DIR}"):
DEV_DIR = d.getVar('DEV_DIR', True)
linux_elphel_label = d.getVar('linux-elphel_label', True)
linux_elphel_branch = d.getVar('linux-elphel_branch', True)
linux_elphel_gitdir = d.getVar('linux-elphel_gitdir', True)
linux_elphel_srcrev = d.getVar('linux-elphel_srcrev', True)
if os.path.isdir(DEV_DIR):
print("Found DEV_DIR, skipping cloning")
print("Found DEV_DIR, skipping cloning")
else:
else:
print("Cloninig
${linux-elphel_label}
\n")
print("Cloninig
"+linux-elphel_label+"
\n")
os.system("git clone -b
${linux-elphel_branch} ${linux-elphel_label} ${linux-elphel_gitdir}"
)
os.system("git clone -b
"+linux_elphel_branch+" "+linux_elphel_label+" "+linux_elphel_gitdir
)
os.system("cd
${linux-elphel_gitdir};git checkout ${linux-elphel_srcrev}"
)
os.system("cd
"+linux_elphel_gitdir+";git checkout "+linux_elphel_srcrev
)
}
}
python do_link() {
python do_link() {
if os.path.isdir("${DEV_DIR}"):
DEV_DIR = d.getVar('DEV_DIR', True)
S = d.getVar('S', True)
TOPDIR = d.getVar('TOPDIR', True)
WORKDIR = d.getVar('WORKDIR', True)
MACHINE = d.getVar('MACHINE', True)
linux_elphel_gitdir = d.getVar('linux-elphel_gitdir', True)
if os.path.isdir(DEV_DIR):
print("DEV_DIR exists - creating links...")
print("DEV_DIR exists - creating links...")
devdir_abspath = os.path.abspath(
"${DEV_DIR}
/src")
devdir_abspath = os.path.abspath(
DEV_DIR+"
/src")
for path, folders, files in os.walk(
"${DEV_DIR}
/src"):
for path, folders, files in os.walk(
DEV_DIR+"
/src"):
folders[:]=[fd for fd in folders if fd != ".git"]
folders[:]=[fd for fd in folders if fd != ".git"]
for folder in folders:
for folder in folders:
folder_abspath = os.path.abspath(os.path.join(path, folder))
folder_abspath = os.path.abspath(os.path.join(path, folder))
folder_relpath = folder_abspath.replace(devdir_abspath+"/", '')
folder_relpath = folder_abspath.replace(devdir_abspath+"/", '')
os.system("cd
${S}
;mkdir -p "+folder_relpath)
os.system("cd
"+S+"
;mkdir -p "+folder_relpath)
for filename in files:
for filename in files:
file_abspath = os.path.abspath(os.path.join(path, filename))
file_abspath = os.path.abspath(os.path.join(path, filename))
file_relpath = file_abspath.replace(devdir_abspath+"/", '')
file_relpath = file_abspath.replace(devdir_abspath+"/", '')
os.system("cd
${S}
;ln -sf "+file_abspath+" "+file_relpath)
os.system("cd
"+S+"
;ln -sf "+file_abspath+" "+file_relpath)
#os.system("cd ${DEV_DIR}; ln -sf ${S} linux")
#os.system("cd "+DEV_DIR+"; ln -sf "+S+" linux")
if not os.path.isdir("${DEV_DIR}/sysroots"):
if not os.path.isdir(DEV_DIR+"/sysroots"):
os.system("cd ${DEV_DIR}; ln -sf ${TOPDIR}/tmp/sysroots sysroots")
os.system("cd "+DEV_DIR+"; ln -sf "+TOPDIR+"/tmp/sysroots sysroots")
if not os.path.isdir("${DEV_DIR}/linux"):
if not os.path.isdir(DEV_DIR+"/linux"):
os.system("cd ${DEV_DIR}; ln -sf ${WORKDIR}/linux-${MACHINE}-standard-build linux")
os.system("cd "+DEV_DIR+"; ln -sf "+WORKDIR+"/linux-"+MACHINE+"-standard-build linux")
os.system("cd ${DEV_DIR}/linux/source/kernel; ln -sf ${WORKDIR}/linux-${MACHINE}-standard-build/kernel/config_data.h config_data.h")
os.system("cd ${DEV_DIR}/linux/source/kernel/time; ln -sf ${WORKDIR}/linux-${MACHINE}-standard-build/kernel/time/timeconst.h timeconst.h")
os.system("cd ${DEV_DIR}/linux/source/lib; ln -sf ${WORKDIR}/linux-${MACHINE}-standard-build/lib/crc32table.h crc32table.h")
else:
else:
print("Copying
${linux-elphel_gitdir}/src/ over ${S}
\n")
print("Copying
"+linux_elphel_gitdir+"/src/ over "+S+"
\n")
os.system("cp -rfv
${linux-elphel_gitdir}/src/* ${S}"
)
os.system("cp -rfv
"+linux_elphel_gitdir+"/src/* "+S
)
}
}
addtask do_link before do_kernel_configme after do_patch
addtask do_link before do_kernel_configme after do_patch
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment