Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
8fbccba3
Commit
8fbccba3
authored
Aug 03, 2016
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
1. fix 4.4 2. moved device tree to linux-elphel
parent
0282a979
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
46 additions
and
2 deletions
+46
-2
elphel393.conf
conf/machine/elphel393.conf
+1
-1
device-tree.bbappend
recipes-bsp/device-tree/device-tree.bbappend
+26
-1
elphel393.cfg
recipes-kernel/linux/config/elphel393.cfg
+19
-0
No files found.
conf/machine/elphel393.conf
View file @
8fbccba3
...
...
@@ -16,7 +16,7 @@ UBOOT_MACHINE = "elphel393_config"
SERIAL_CONSOLE
=
"115200 ttyPS0"
MACHINE_DEVICETREE
:=
"
\
elphel393
/
elphel393
.
dts
\
elphel393
.
dts
\
"
MACHINE_KCONFIG
:=
"common/elphel393_defconfig_${LINUX_VERSION}"
...
...
recipes-bsp/device-tree/device-tree.bbappend
View file @
8fbccba3
# add dtsi's
SRC_URI += "file://*.dtsi"
DEV_DIR ?= "${TOPDIR}/../../linux-elphel"
python do_unpack(){
DEV_DIR = d.getVar('DEV_DIR', True)
MACHINE = d.getVar('MACHINE', True)
WORKDIR = d.getVar('WORKDIR', True)
if os.path.isdir(DEV_DIR):
print("Found DEV_DIR, skipping something")
DTS_PATH = DEV_DIR+"/src/arch/arm/boot/dts"
MACHINE_DTS = DTS_PATH+"/"+MACHINE+".dts"
if os.path.isfile(MACHINE_DTS):
print("Machine device tree found: "+MACHINE+".dts")
d.setVar('MACHINE_DEVICETREE',MACHINE+".dts")
if not os.path.isdir(WORKDIR+"/devicetree"):
import subprocess
cmd = "ln -sf "+DTS_PATH+" "+WORKDIR+"/devicetree"
try:
res = subprocess.check_output(cmd,stderr=subprocess.STDOUT,shell=True)
except subprocess.CalledProcessError as e:
res = "error_"+e.returncode
else:
bb.build.exec_func('base_do_unpack', d)
}
do_deploy(){
for DTS_FILE in ${DEVICETREE}; do
DTS_NAME=`basename ${DTS_FILE} | awk -F "." '{print $1}'`
...
...
@@ -42,7 +67,7 @@ do_compile() {
for DTS_FILE in ${DEVICETREE}; do
DTS_NAME=`basename ${DTS_FILE} | awk -F "." '{print $1}'`
for RLOC in ${PRODUCTION_ROOT_LOCATION}; do
ln -sf ${WORKDIR}/devicetree/bootargs-${RLOC}.dtsi ${WORKDIR}/devicetree/bootargs.dtsi
ln -sf ${WORKDIR}/devicetree/
${MACHINE}-
bootargs-${RLOC}.dtsi ${WORKDIR}/devicetree/bootargs.dtsi
dtc -I dts -O dtb ${DEVICETREE_FLAGS} -o ${DTS_NAME}_${RLOC}.dtb ${DTS_FILE}
done
done
...
...
recipes-kernel/linux/config/elphel393.cfg
View file @
8fbccba3
...
...
@@ -82,3 +82,22 @@ CONFIG_RTL8192CU=y
CONFIG_LEGACY_PTYS=y
CONFIG_OVERLAY_FS=y
# config CPU_SW_DOMAIN_PAN
# bool "Enable use of CPU domains to implement privileged no-access"
# depends on MMU && !ARM_LPAE
# default y
# help
# Increase kernel security by ensuring that normal kernel accesses
# are unable to access userspace addresses. This can help prevent
# use-after-free bugs becoming an exploitable privilege escalation
# by ensuring that magic values (such as LIST_POISON) will always
# fault when dereferenced.
#
# CPUs with low-vector mappings use a best-efforts implementation.
# Their lower 1MB needs to remain accessible for the vectors, but
# the remainder of userspace will become appropriately inaccessible.
#
# 1. https://github.com/raspberrypi/linux/pull/1178#issuecomment-163651327
# 2. http://www.gossamer-threads.com/lists/linux/kernel/2317439
CONFIG_CPU_SW_DOMAIN_PAN=n
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment