Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
777291cc
Commit
777291cc
authored
Dec 01, 2017
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
updates for rocko
parent
fa20ebf2
Changes
6
Hide whitespace changes
Inline
Side-by-side
Showing
6 changed files
with
50 additions
and
16 deletions
+50
-16
apps-astreamer_1.0.bb
recipes-core/apps-astreamer/apps-astreamer_1.0.bb
+1
-1
fpga-x393_1.0.bb
recipes-core/fpga-x393/fpga-x393_1.0.bb
+17
-2
fpga-x393sata_1.0.bb
recipes-core/fpga-x393sata/fpga-x393sata_1.0.bb
+7
-1
core-image-elphel393.bb
recipes-core/images/core-image-elphel393.bb
+23
-11
web-393_1.0.bb
recipes-core/web-393/web-393_1.0.bb
+1
-0
lighttpd_1.%.bbappend
recipes-extended/lighttpd/lighttpd_1.%.bbappend
+1
-1
No files found.
recipes-core/apps-astreamer/apps-astreamer_1.0.bb
View file @
777291cc
...
...
@@ -18,6 +18,6 @@ DEPENDS += "alsa-lib"
# needed for sysroot?
#DEPENDS += "apache2"
RDEPENDS_apps-astreamer += "alsa-lib"
#
RDEPENDS_apps-astreamer += "alsa-lib"
FILES_${PN} += " ${base_prefix}/usr/bin/*"
recipes-core/fpga-x393/fpga-x393_1.0.bb
View file @
777291cc
SUMMARY = "core FPGA code"
SUMMARY = "core FPGA code"
AUTHOR = "Elphel Inc."
HOMEPAGE = "http://www3.elphel.com/"
...
...
@@ -12,5 +12,20 @@ inherit elphel-dev
do_configure[noexec] = "1"
#do_compile[noexec] = "1"
RDEPENDS_${PN} += "python-core"
FILES_${PN} += " ${base_prefix}/www/pages/* ${base_prefix}/usr/local/verilog/* ${base_prefix}/usr/local/bin/*"
FILES_${PN} += " ${base_prefix}/www/pages/* \
${base_prefix}/usr/local/verilog/* \
${base_prefix}/usr/local/bin/* \
"
do_install_append() {
rm ${D}/usr/local/bin/x393_mem.py
}
# THIS ONLY WORKS FOR /usr/bin/
#inherit update-alternatives
#ALTERNATIVE_PRIORITY = "100"
## ../ to get out from ${bindir} = /usr/bin/
#ALTERNATIVE_${PN} = "../local/bin/x393_mem.py"
recipes-core/fpga-x393sata/fpga-x393sata_1.0.bb
View file @
777291cc
SUMMARY = "FPGA code for AHCI SATA (already duplicated in x393 main project, only Python scripts are used)"
SUMMARY = "FPGA code for AHCI SATA (already duplicated in x393 main project, only Python scripts are used)"
AUTHOR = "Elphel Inc."
HOMEPAGE = "http://www3.elphel.com/"
...
...
@@ -14,3 +14,9 @@ do_configure[noexec] = "1"
#do_compile[noexec] = "1"
RDEPENDS_${PN} += "python-core"
FILES_${PN} += " ${base_prefix}/usr/local/verilog/* ${base_prefix}/usr/local/bin/* ${base_prefix}/www/pages/*"
# THIS ONLY WORKS FOR /usr/bin/
#inherit update-alternatives
#ALTERNATIVE_PRIORITY = "50"
## ../ to get out from ${bindir} = /usr/bin/
#ALTERNATIVE_${PN} = "../local/bin/x393_mem.py"
recipes-core/images/core-image-elphel393.bb
View file @
777291cc
...
...
@@ -129,28 +129,40 @@ UBINIZE_ARGS = " -m 2048 -p 128KiB -s 2048"
create_symlinks_append(){
IMAGE_NAME = d.getVar('IMAGE_NAME')
DEPLOY_DIR_IMAGE = d.getVar('DEPLOY_DIR_IMAGE')
PRODUCTION_ROOTFS = d.getVar('PRODUCTION_ROOTFS')
rlocs = (d.getVar('PRODUCTION_ROOT_LOCATION', True)).split()
for rloc in rlocs:
if not os.path.isdir(
"${DEPLOY_DIR_IMAGE}
/"+rloc):
os.system("mkdir
${DEPLOY_DIR_IMAGE}
/"+rloc)
if not os.path.isdir(
DEPLOY_DIR_IMAGE+"
/"+rloc):
os.system("mkdir
"+DEPLOY_DIR_IMAGE+"
/"+rloc)
if (rloc=="mmc"):
image_ext = "
.
tar.gz"
image_ext = "tar.gz"
image_ext2 = ""
else:
image_ext = ".ubifs"
image_ext2 = ".ubi"
image_ext = "ubifs"
image_ext2 = "ubi"
fname = os.path.join(deploy_dir, img_name + imgsuffix + image_ext)
if os.path.exists(fname):
tmp_fname = DEPLOY_DIR_IMAGE+"/"+rloc+"/"+PRODUCTION_ROOTFS+"."+image_ext
if os.path.isfile("${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs"+image_ext):
tmp_fname = "${DEPLOY_DIR_IMAGE}/"+rloc+"/${PRODUCTION_ROOTFS}"+image_ext
if os.path.isfile(tmp_fname):
os.system("rm "+tmp_fname)
os.system("cp ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs"+image_ext+" "+tmp_fname)
os.system("cp "+fname+" "+tmp_fname)
if not image_ext2=="":
if os.path.isfile("${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs"+image_ext2):
tmp_fname = "${DEPLOY_DIR_IMAGE}/"+rloc+"/${PRODUCTION_ROOTFS}"+image_ext2
fname2 = os.path.join(deploy_dir, img_name + imgsuffix + image_ext2)
if os.path.exists(fname2):
tmp_fname = DEPLOY_DIR_IMAGE+"/"+rloc+"/"+PRODUCTION_ROOTFS+"."+image_ext2
if os.path.isfile(tmp_fname):
os.system("rm "+tmp_fname)
os.system("cp ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs"+image_ext2+" "+tmp_fname)
os.system("cp "+fname2+" "+tmp_fname)
}
recipes-core/web-393/web-393_1.0.bb
View file @
777291cc
...
...
@@ -14,3 +14,4 @@ do_configure[noexec] = "1"
#do_compile[noexec] = "1"
FILES_${PN} += " ${base_prefix}/www/pages/* ${base_prefix}/usr/local/bin/*"
recipes-extended/lighttpd/lighttpd_1.%.bbappend
View file @
777291cc
...
...
@@ -10,7 +10,7 @@ CONFFILES_${PN} = "${D}/lighttpd.conf"
do_install_append() {
cp ${WORKDIR}/test.py ${D}/www/pages/test.py
cp ${WORKDIR}/phpinfo.php ${D}/www/pages/phpinfo.php
#
cp ${WORKDIR}/phpinfo.php ${D}/www/pages/phpinfo.php
cp ${WORKDIR}/eth0-down-up-test.sh ${D}/www/pages/eth0-down-up-test.sh
rm -f ${D}/www/pages/index.html
}
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment