Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
68bfc069
Commit
68bfc069
authored
Aug 11, 2016
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
udev-rules makefile based package
parent
2c093218
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
26 additions
and
31 deletions
+26
-31
elphel-dev.bbclass
classes/elphel-dev.bbclass
+17
-0
elphel-misc.bbclass
classes/elphel-misc.bbclass
+7
-0
udev-rules_1.0.bb
recipes-core/udev-rules/udev-rules_1.0.bb
+2
-31
No files found.
classes/elphel-dev.bbclass
0 → 100644
View file @
68bfc069
# developers version
inherit elphel-misc
do_unpack(){
if [ -d ${S} ]; then
rm -rf ${S}
ln -sf ${VPATH} ${S}
fi
}
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install_append() {
oe_runmake 'DESTDIR=${D}' install
}
\ No newline at end of file
classes/elphel-misc.bbclass
View file @
68bfc069
...
...
@@ -32,3 +32,10 @@ def revision_update(path,file):
res = str(int(res))
res = res.strip(' \t\n\r')
return res
VFILE = "VERSION"
PE = "${@version_update('${VPATH}','${VFILE}',0)}"
PV = "${@version_update('${VPATH}','${VFILE}',1)}"
PR = "${@version_update('${VPATH}','${VFILE}',2)}"
FILESEXTRAPATHS_append := "${VPATH}:"
\ No newline at end of file
recipes-core/udev-rules/udev-rules_1.0.bb
View file @
68bfc069
SUMMARY = "Extra initscripts for the Elphel 10393 board"
DESCRIPTION = "udev rules for automounting disk drives to /mnt or /media directories"
AUTHOR = "Elphel Inc."
HOMEPAGE = "http://www3.elphel.com/"
PRIORITY = "optional"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891"
SRCDATE = "20160810"
# PV,PR update
inherit elphel-misc
VPATH = "${TOPDIR}/../../rootfs-elphel/elphel-udev-rules"
VFILE = "VERSION"
PE = "${@version_update('${VPATH}','${VFILE}',0)}"
PV = "${@version_update('${VPATH}','${VFILE}',1)}"
PR = "${@version_update('${VPATH}','${VFILE}',2)}"
S = "${WORKDIR}"
FILESEXTRAPATHS_append := "${VPATH}:"
SRC_URI = "file://90-elphel-automount.rules \
file://static.sh \
"
RDEPENDS_${PN} = "udev"
PACKAGES = "udev-rules"
UDEV_RULES_DIR = "${sysconfdir}/udev/rules.d"
FILES_${PN} += " ${UDEV_RULES_DIR}/90-elphel-automount.rules /lib/udev/devices "
do_install() {
install -d ${D}${UDEV_RULES_DIR}
install -m 644 ${WORKDIR}/90-elphel-automount.rules ${D}${UDEV_RULES_DIR}
install -d ${D}${nonarch_base_libdir}/udev/devices
${WORKDIR}/static.sh ${D}${nonarch_base_libdir}/udev/devices
}
inherit elphel-dev
FILES_${PN} += " /lib/udev/devices/* /etc/udev/rules.d/*"
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment