Commit 55b52ae2 authored by Oleg Dzhimiev's avatar Oleg Dzhimiev

1.dts with partitions 2.removed a patch

parent d7c8109b
......@@ -414,8 +414,24 @@
#address-cells = <0x1>;
#size-cells = <0x1>;
partition@0 {
label = "nand-main";
reg = <0x0 0x4000000>;/*64MB*/
label = "u-boot-spl";
reg = <0x0 0x40000>;/*256KB*/
};
partition@1 {
label = "u-boot";
reg = <0x40000 0x100000>;/*1MB*/
};
partition@2 {
label = "device-tree";
reg = <0x140000 0x100000>;/*1MB*/
};
partition@3 {
label = "kernel";
reg = <0x240000 0x1000000>;/*16MB*/
};
partition@4 {
label = "rootfs";
reg = <0x1240000 0x4000000>;/*64MB*/
};
} ;
} ;
......
diff --git a/drivers/ata/Kconfig b/drivers/ata/Kconfig
index 5f60155..5d93116 100644
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
@@ -157,6 +157,16 @@ config AHCI_XGENE
help
This option enables support for APM X-Gene SoC SATA host controller.
+config AHCI_ELPHEL
+ tristate "Elphel AHCI SATA driver support for elphel393 camera series"
+ depends on ARM
+ default m if ARM
+ help
+ This option enables support for Elphel AHCI SATA controller in elphel393
+ series cameras.
+
+ If unsure, say N.
+
config SATA_FSL
tristate "Freescale 3.0Gbps SATA support"
depends on FSL_SOC
diff --git a/drivers/ata/Makefile b/drivers/ata/Makefile
index ae41107..212dfed 100644
--- a/drivers/ata/Makefile
+++ b/drivers/ata/Makefile
@@ -5,6 +5,7 @@ obj-$(CONFIG_ATA) += libata.o
obj-$(CONFIG_SATA_AHCI) += ahci.o libahci.o
obj-$(CONFIG_SATA_ACARD_AHCI) += acard-ahci.o libahci.o
obj-$(CONFIG_SATA_AHCI_PLATFORM) += ahci_platform.o libahci.o libahci_platform.o
+obj-$(CONFIG_AHCI_ELPHEL) += ahci_elphel.o libahci.o libahci_platform.o
obj-$(CONFIG_SATA_FSL) += sata_fsl.o
obj-$(CONFIG_SATA_INIC162X) += sata_inic162x.o
obj-$(CONFIG_SATA_SIL24) += sata_sil24.o
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment