Commit 4e123d0c authored by Mikhail Karpenko's avatar Mikhail Karpenko

add AHCI driver patch

parent c5237f99
...@@ -448,6 +448,14 @@ ...@@ -448,6 +448,14 @@
interrupt-parent = <&ps7_scugic_0>; interrupt-parent = <&ps7_scugic_0>;
interrupts = <0 7 4>; interrupts = <0 7 4>;
} ; } ;
elphel_ahci: elphel-ahci@80000000 {
compatible = "elphel,elphel-ahci";
interrupt-parent = <&ps7_scugic_0>;
interrupts = <0x0 0x1d 0x4>;
reg = <0x80000000 0x1000>;
clb_offs = <0x800>;
fb_offs = <0xc00>;
};
} ; } ;
elphel393_pwr: elphel393-pwr@0 { elphel393_pwr: elphel393-pwr@0 {
compatible = "elphel,elphel393-pwr-1.00"; compatible = "elphel,elphel393-pwr-1.00";
......
...@@ -22,4 +22,12 @@ CONFIG_CMA_SIZE_SEL_MBYTES=y ...@@ -22,4 +22,12 @@ CONFIG_CMA_SIZE_SEL_MBYTES=y
CONFIG_CMA_ALIGNMENT=8 CONFIG_CMA_ALIGNMENT=8
#CONFIG_CMA_AREAS=7 #obsolete #CONFIG_CMA_AREAS=7 #obsolete
CONFIG_MTD_TESTS=y CONFIG_MTD_TESTS=y
\ No newline at end of file
#
# AHCI driver related configs
#
CONFIG_ATA=y
CONFIG_ATA_VERBOSE_ERROR=y
CONFIG_SATA_AHCI_PLATFORM=y
CONFIG_AHCI_ELPHEL=M
diff --git a/drivers/ata/Kconfig b/drivers/ata/Kconfig
index 5f60155..5d93116 100644
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
@@ -157,6 +157,16 @@ config AHCI_XGENE
help
This option enables support for APM X-Gene SoC SATA host controller.
+config AHCI_ELPHEL
+ tristate "Elphel AHCI SATA driver support for elphel393 camera series"
+ depends on ARM
+ default m if ARM
+ help
+ This option enables support for Elphel AHCI SATA controller in elphel393
+ series cameras.
+
+ If unsure, say N.
+
config SATA_FSL
tristate "Freescale 3.0Gbps SATA support"
depends on FSL_SOC
diff --git a/drivers/ata/Makefile b/drivers/ata/Makefile
index ae41107..212dfed 100644
--- a/drivers/ata/Makefile
+++ b/drivers/ata/Makefile
@@ -5,6 +5,7 @@ obj-$(CONFIG_ATA) += libata.o
obj-$(CONFIG_SATA_AHCI) += ahci.o libahci.o
obj-$(CONFIG_SATA_ACARD_AHCI) += acard-ahci.o libahci.o
obj-$(CONFIG_SATA_AHCI_PLATFORM) += ahci_platform.o libahci.o libahci_platform.o
+obj-$(CONFIG_AHCI_ELPHEL) += ahci_elphel.o libahci.o libahci_platform.o
obj-$(CONFIG_SATA_FSL) += sata_fsl.o
obj-$(CONFIG_SATA_INIC162X) += sata_inic162x.o
obj-$(CONFIG_SATA_SIL24) += sata_sil24.o
...@@ -6,6 +6,7 @@ SRC_URI_append += " file://xilinx_emacps.c.patch" ...@@ -6,6 +6,7 @@ SRC_URI_append += " file://xilinx_emacps.c.patch"
SRC_URI_append += " file://xilinx_uartps.c.patch" SRC_URI_append += " file://xilinx_uartps.c.patch"
SRC_URI_append += " file://si5338_vsc330x.patch" SRC_URI_append += " file://si5338_vsc330x.patch"
SRC_URI_append += " file://drivers-elphel.patch" SRC_URI_append += " file://drivers-elphel.patch"
SRC_URI_append += " file://drivers-ahci-elphel.patch"
SRC_URI_append += " file://${MACHINE}.scc" SRC_URI_append += " file://${MACHINE}.scc"
KERNEL_FEATURES_append = " ${MACHINE}.scc" KERNEL_FEATURES_append = " ${MACHINE}.scc"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment