Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
3fef028f
Commit
3fef028f
authored
Jul 21, 2016
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
PV,PR
parent
7e1bb078
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
27 additions
and
2 deletions
+27
-2
elphel-misc.bbclass
classes/elphel-misc.bbclass
+18
-0
init-elphel393_1.0.bb
recipes-core/init-elphel393/init-elphel393_1.0.bb
+9
-2
No files found.
classes/elphel-misc.bbclass
0 → 100644
View file @
3fef028f
# Well
# returns string - based on file
def version_update(path,file):
with open(path+'/'+file, 'r') as content_file:
content = content_file.read()
content = content.strip(' \t\n\r')
return content
def revision_update(path,file):
import subprocess
cmd = "cd "+path+"; git rev-list --count $(git log -1 --pretty=format:\"%H\" "+file+")..HEAD"
try:
res = subprocess.check_output(cmd,stderr=subprocess.STDOUT,shell=True)
except subprocess.CalledProcessError as e:
res = "error_"+e.returncode
res = res.strip(' \t\n\r')
return res
recipes-core/init-elphel393/init-elphel393_1.0.bb
View file @
3fef028f
...
@@ -13,8 +13,15 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-3.0;md5=c79ff39f19dfec6d293
...
@@ -13,8 +13,15 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-3.0;md5=c79ff39f19dfec6d293
SRCDATE = "20131202"
SRCDATE = "20131202"
PV = "${SRCDATE}"
#PV = "${SRCDATE}"
PR = "r0"
#PR = "r0"
# PV,PR update
inherit elphel-misc
VPATH = "${TOPDIR}/../../fpga-elphel/x393"
VFILE = "VERSION"
PV = "${@version_update ('${VPATH}','${VFILE}')}"
PR = "${@revision_update('${VPATH}','${VFILE}')}"
RDEPENDS_${PN} += "\
RDEPENDS_${PN} += "\
python-core \
python-core \
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment