Commit 0d9a6559 authored by YuriNenakhov's avatar YuriNenakhov

Two sets of drivers supported (for camera and for testing on zedboard)

parent 8b999d77
...@@ -2785,3 +2785,6 @@ CONFIG_KVM_ARM_MAX_VCPUS=0 ...@@ -2785,3 +2785,6 @@ CONFIG_KVM_ARM_MAX_VCPUS=0
# #
# Virtio drivers # Virtio drivers
# #
CONFIG_ELPHELDRVONMICROZED=y
...@@ -418,4 +418,8 @@ ...@@ -418,4 +418,8 @@
elphel393_pwr,channels_enable= "vcc_sens01 vp33sens01"; elphel393_pwr,channels_enable= "vcc_sens01 vp33sens01";
} ; } ;
elphel393_mem: elphel393-mem@0 {
compatible = "elphel,elphel393-mem-1.00";
memsize = <25600>;
} ;
} ; } ;
...@@ -319,4 +319,8 @@ ...@@ -319,4 +319,8 @@
reg = <0xf8007100 0x20>; reg = <0xf8007100 0x20>;
} ; } ;
} ; } ;
elphel393_mem: elphel393-mem@0 {
compatible = "elphel,elphel393-mem-1.00";
memsize = <25600>;
} ;
} ; } ;
...@@ -13,9 +13,11 @@ Index: git/drivers/Makefile ...@@ -13,9 +13,11 @@ Index: git/drivers/Makefile
=================================================================== ===================================================================
--- git.orig/drivers/Makefile 2013-12-19 21:21:09.941007583 -0700 --- git.orig/drivers/Makefile 2013-12-19 21:21:09.941007583 -0700
+++ git/drivers/Makefile 2013-12-20 22:32:20.929948050 -0700 +++ git/drivers/Makefile 2013-12-20 22:32:20.929948050 -0700
@@ -156,3 +156,5 @@ @@ -156,3 +156,6 @@
obj-y += xilinx_common/ obj-y += xilinx_common/
obj-$(CONFIG_PMODS) += pmods/ obj-$(CONFIG_PMODS) += pmods/
+ +
+obj-$(CONFIG_ELPHEL393) += elphel/ +obj-$(CONFIG_ELPHEL393) += elphel/
+obj-$(CONFIG_ELPHELDRVONMICROZED) += elphel/
...@@ -53,3 +53,4 @@ do_unpack_append() { ...@@ -53,3 +53,4 @@ do_unpack_append() {
print("Copying ${linux-elphel_gitdir}/src/ over ${S}\n") print("Copying ${linux-elphel_gitdir}/src/ over ${S}\n")
os.system("cp -rfv ${linux-elphel_gitdir}/src/* ${S}") os.system("cp -rfv ${linux-elphel_gitdir}/src/* ${S}")
} }
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment