Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-ezynq
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-ezynq
Commits
b976a688
Commit
b976a688
authored
Jan 20, 2016
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
changes for newer u-boot
parent
626e02fc
Changes
3
Show whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
19 additions
and
18 deletions
+19
-18
u-boot-ezynq-tasks.inc
recipes-bsp/u-boot/u-boot-ezynq-tasks.inc
+7
-7
u-boot-ezynq.inc
recipes-bsp/u-boot/u-boot-ezynq.inc
+8
-9
u-boot-ezynq_2016.01.bb
recipes-bsp/u-boot/u-boot-ezynq_2016.01.bb
+4
-2
No files found.
recipes-bsp/u-boot/u-boot-ezynq-tasks.inc
View file @
b976a688
...
...
@@ -20,7 +20,7 @@ do_fetch(){
echo
"Skipped: ezynq is already cloned."
fi
echo
"Fetching
u-boot-xlnx
..."
echo
"Fetching
${GITDIR_uboot_dir}
..."
if
[
!
-
d
"${GITDIR_uboot}/.git"
];
then
# not really needed - for consistency
if
[
-
d
$
{
GITDIR_uboot
}
];
then
...
...
@@ -30,9 +30,9 @@ do_fetch(){
cd
$
{
GITDIR_uboot
}
git
checkout
$
{
SRCREV_uboot
}
cd
$
{
WORKDIR
}
echo
"Cloning
u-boot-xlnx
done."
echo
"Cloning
${GITDIR_uboot_dir}
done."
else
echo
"Skipped:
u-boot-xlnx
is already cloned."
echo
"Skipped:
${GITDIR_uboot_dir}
is already cloned."
fi
}
...
...
@@ -86,9 +86,9 @@ do_compile(){
echo
"Compiling..."
cd
$
{
GITDIR_uboot
}
echo
"Running ezynqcfg.py for the first time - u-boot length is not known yet, generating arch/arm/
cpu/armv7/
zynq/ezynq.c"
echo
"Running ezynqcfg.py for the first time - u-boot length is not known yet, generating arch/arm/
mach-
zynq/ezynq.c"
$
{
GITDIR_ezynq_label
}
/
ezynqcfg
.
py
-
c
include
/
autoconf
.
mk
--
html
u
-
boot
.
html
-
o
boot_head
.
bin
--
html
-
mask
0x3ff
--
lowlevel
arch
/
arm
/
cpu
/
armv7
/
zynq
/
ezynq
.
c
$
{
GITDIR_ezynq_label
}
/
ezynqcfg
.
py
-
c
include
/
autoconf
.
mk
--
html
u
-
boot
.
html
-
o
boot_head
.
bin
--
html
-
mask
0x3ff
--
lowlevel
arch
/
arm
/
mach
-
zynq
/
ezynq
.
c
unset
LDFLAGS
unset
CFLAGS
...
...
@@ -99,13 +99,13 @@ do_compile(){
echo
"Other files are already created, repeating it here just to remind their paths"
if
[
$
(
cat
include
/
autoconf
.
mk
|
grep
"CONFIG_SPL=y"
)
];
then
if
[
$
(
cat
.
config
|
grep
"CONFIG_SPL=y"
)
];
then
UBOOT_FILE
=
"spl/u-boot-spl.bin"
else
UBOOT_FILE
=
"u-boot.bin"
fi
$
{
GITDIR_ezynq_label
}
/
ezynqcfg
.
py
-
c
include
/
autoconf
.
mk
-
o
boot_head
.
bin
--
uboot
$UBOOT_FILE
--
html
u
-
boot
.
html
--
html
-
mask
0x3ff
--
lowlevel
arch
/
arm
/
cpu
/
armv7
/
zynq
/
ezynq
.
c
$
{
GITDIR_ezynq_label
}
/
ezynqcfg
.
py
-
c
include
/
autoconf
.
mk
-
o
boot_head
.
bin
--
uboot
$UBOOT_FILE
--
html
u
-
boot
.
html
--
html
-
mask
0x3ff
--
lowlevel
arch
/
arm
/
mach
-
zynq
/
ezynq
.
c
cat
boot_head
.
bin
$UBOOT_FILE
>
boot
.
bin
...
...
recipes-bsp/u-boot/u-boot-ezynq.inc
View file @
b976a688
require
recipes
-
bsp
/
u
-
boot
/
u
-
boot
.
inc
LICENSE
=
"GPLv2+ & GPLv3"
LIC_FILES_CHKSUM
=
"file://${GITDIR_uboot}/README;md5=
8872462bd018b07588642610ee65380e
\
LIC_FILES_CHKSUM
=
"file://${GITDIR_uboot}/README;md5=
587d8d939ae351bb11910921b1eafd42
\
file://${GITDIR_ezynq}/LICENSE;md5=891e49b3c2a8c133ffe7985e54245aff"
# working directory
...
...
@@ -12,9 +12,6 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
##########################################################################################
# Defining u-boot.inc parameters
# UBOOT_MACHINE is defined in meta-<board>/conf/machine/<board>.conf
# (e.g., meta-microzed/conf/machine/microzed.conf: UBOOT_MACHINE= zynq_microzed_config)
UBOOT_SUFFIX
=
"img"
UBOOT_IMAGE
=
"u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_BINARY
=
"u-boot.${UBOOT_SUFFIX}"
...
...
@@ -33,23 +30,25 @@ GITDIR_ezynq_label = "ezynq"
GITDIR_ezynq
=
"${WORKDIR}/${GITDIR_ezynq_dir}"
GITDIR_ezynq_u
-
boot
-
tree
=
"${GITDIR_ezynq}/u-boot-tree"
GITDIR_uboot_dir
=
"u-boot
-xlnx
"
GITDIR_uboot_dir
=
"u-boot"
GITDIR_uboot
=
"${WORKDIR}/git/${GITDIR_uboot_dir}"
SRC_URI_ezynq
=
"git://github.com/Elphel/ezynq.git"
SRC_URI_ezynq_branch
=
"master"
SRC_URI_uboot
=
"git://git
hub.com/Xilinx/u-boot-xlnx
.git"
SRC_URI_uboot_branch
=
"master
-next
"
SRC_URI_uboot
=
"git://git
.denx.de/u-boot
.git"
SRC_URI_uboot_branch
=
"master"
#SRCREV_ezynq= "83340698f9669977b7205aa67e6ca0dd23fb741f"
#SRCREV_ezynq= "89bb3ac2ed47ae48460e4dd82829d765b7922269"
SRCREV_ezynq
=
"80f478a416f48fc5dc0485bcee220bba6132acd3"
#SRCREV_ezynq= "80f478a416f48fc5dc0485bcee220bba6132acd3"
SRCREV_ezynq
=
""
#SRCREV_uboot= "bbd91fc9ae290c31dc52fd8322f43f67ddd39247"
#SRCREV_uboot= "6742f65365086ded52fa9726c9120de8a6ad541b"
#SRCREV_uboot= "54fee227ef141214141a226efd17ae0516deaf32"
SRCREV_uboot
=
"2a0536fa48db1fc5332e3cd33b846d0da0c8bc1e"
#SRCREV_uboot= "2a0536fa48db1fc5332e3cd33b846d0da0c8bc1e"
SRCREV_uboot
=
"fa85e826c16b9ce1ad302a57e9c4b24db0d8b930"
PATCH_NAME
=
"ezynq.patch"
...
...
recipes-bsp/u-boot/u-boot-ezynq_201
3
.01.bb
→
recipes-bsp/u-boot/u-boot-ezynq_201
6
.01.bb
View file @
b976a688
...
...
@@ -3,10 +3,12 @@ HOMEPAGE = "http://elphel.com;http://blog.elphel.com"
SECTION = "bootloaders"
#Project Version
PV = "v201
4.03
"
PV = "v201
6.01
"
#Project Revision
PR = "r0"
include u-boot-ezynq.inc
PROVIDES = "u-boot virtual/bootloader"
inherit zynq7-platform-paths
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment