Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-ezynq
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-ezynq
Commits
a84b719a
Commit
a84b719a
authored
Dec 27, 2018
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
temporarily provide binaries until u-boot gets fixed
parent
046de13c
Changes
3
Expand all
Show whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
417 additions
and
3 deletions
+417
-3
u-boot-ezynq-binaries.bb
recipes-bsp/u-boot/u-boot-ezynq-binaries.bb
+103
-0
u-boot-ezynq.inc
recipes-bsp/u-boot/u-boot-ezynq.inc
+7
-3
u-boot.inc
recipes-bsp/u-boot/u-boot.inc
+307
-0
No files found.
recipes-bsp/u-boot/u-boot-ezynq-binaries.bb
0 → 100644
View file @
a84b719a
PROVIDES = "u-boot u-boot-ezynq"
LICENSE = "GPLv2+ & GPLv3"
LIC_FILES_CHKSUM = "file://${GITDIR_ezynq}/LICENSE;md5=891e49b3c2a8c133ffe7985e54245aff"
PACKAGE_ARCH = "${MACHINE_ARCH}"
PACKAGES = "u-boot-ezynq"
FILES_u-boot-ezynq = "/boot"
GITDIR_ezynq_dir= "git"
GITDIR_ezynq_label = "ezynq"
GITDIR_ezynq= "${WORKDIR}/${GITDIR_ezynq_dir}"
GITDIR_ezynq_bindir = "${GITDIR_ezynq}/images/elphel393"
S = "${GITDIR_ezynq}"
B = "${S}"
ELPHELGITHOST ??= "git.elphel.com"
SRC_URI_ezynq= "https://${ELPHELGITHOST}/Elphel/ezynq.git"
SRC_URI_ezynq_branch= "master"
##########################################################################################
# Defining u-boot.inc parameters
UBOOT_SUFFIX = "img"
UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_BINARY = "u-boot.${UBOOT_SUFFIX}"
UBOOT_SYMLINK = "u-boot-${MACHINE}.${UBOOT_SUFFIX}"
UBOOT_MAKE_TARGET = "all"
SPL_SUFFIX = "bin"
SPL_BINARY = "boot.${SPL_SUFFIX}"
SPL_IMAGE = "boot-${MACHINE}-${PV}-${PR}.${SPL_SUFFIX}"
SPL_SYMLINK = "boot-${MACHINE}.${SPL_SUFFIX}"
# Tasks
# partially from u-boot-ezynq-tasks.inc
# when updating from Jethro to Rocko 'cleandirs' is set for S
# So it happily nukes a freshly cloned u-boot repo, so:
# unsetting cleandirs flag:
python(){
d.setVarFlag('do_unpack','cleandirs', '')
}
##########################################################################################
# SRC_URI - Couldn't find how to deal with multiple git repos:
# 1. Tried and it didn't work: http://lists.linuxtogo.org/pipermail/openembedded-core/2011-October/010926.html
# 2. No *.bb examples found
# Overriding do_fetch:
do_fetch(){
echo "Fetching ezynq..."
if [ ! -d "${GITDIR_ezynq}/.git" ]; then
# if anything left after do_clean - delete it
if [ -d ${GITDIR_ezynq} ]; then
rm -r ${GITDIR_ezynq}
fi
git clone -b ${SRC_URI_ezynq_branch} ${SRC_URI_ezynq} ${GITDIR_ezynq}
cd ${GITDIR_ezynq}
git checkout ${SRCREV_ezynq}
cd ${WORKDIR}
echo "Cloning ezynq done."
else
echo "Skipped: ezynq is already cloned."
fi
}
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install(){
install -d ${D}/boot
install -m 644 ${GITDIR_ezynq_bindir}/boot.bin ${D}/boot/boot.bin
install -m 644 ${GITDIR_ezynq_bindir}/u-boot-dtb.img ${D}/boot/u-boot-dtb.img
}
inherit deploy
do_deploy(){
install -d ${DEPLOYDIR}
install -m 644 ${GITDIR_ezynq_bindir}/boot.bin ${DEPLOYDIR}/boot.bin
install -m 644 ${GITDIR_ezynq_bindir}/u-boot-dtb.img ${DEPLOYDIR}/u-boot-dtb.img
cd ${DEPLOYDIR}
for RLOC in ${PRODUCTION_ROOT_LOCATION}; do
if [ ! -d ${RLOC} ]; then
mkdir ${RLOC}
fi
if [ -f ${RLOC}/boot.bin ]; then
rm ${RLOC}/boot.bin
fi
cp boot.bin ${RLOC}/
if [ -f ${RLOC}/u-boot-dtb.img ]; then
rm ${RLOC}/u-boot-dtb.img
fi
cp u-boot-dtb.img ${RLOC}/u-boot-dtb.img
done
}
addtask deploy before do_build after do_compile
recipes-bsp/u-boot/u-boot-ezynq.inc
View file @
a84b719a
require
recipes
-
bsp
/
u
-
boot
/
u
-
boot
.
inc
require
u
-
boot
.
inc
DEPENDS
+=
"bc-native dtc-native"
DEPENDS
=
"bc-native dtc-native"
#require recipes-bsp/u-boot/u-boot.inc
#DEPENDS += " bc-native dtc-native"
LICENSE
=
"GPLv2+ & GPLv3"
LIC_FILES_CHKSUM
=
"file://${GITDIR_uboot}/README;md5=f0b2103a037ad81f10894cc74e3b6212 \
...
...
@@ -59,6 +61,8 @@ SRCREV_ezynq= ""
#SRCREV_uboot= "2a0536fa48db1fc5332e3cd33b846d0da0c8bc1e"
#SRCREV_uboot= "fa85e826c16b9ce1ad302a57e9c4b24db0d8b930"
SRCREV_uboot
=
"aeaec0e682f45b9e0c62c522fafea353931f73ed"
#SRCREV_uboot= "8c5d4fd0ec222701598a27b26ab7265d4cee45a3"
#SRCREV_uboot= "0157013f4a4945bbdb70bb4d98d680e0845fd784"
#for u-boot-xlnx
#SRCREV_uboot= "01b1fea9b13b799a16efd743587dc861719e5212"
...
...
recipes-bsp/u-boot/u-boot.inc
0 → 100644
View file @
a84b719a
This diff is collapsed.
Click to expand it.
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment