Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-ezynq
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-ezynq
Commits
a84b719a
Commit
a84b719a
authored
Dec 27, 2018
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
temporarily provide binaries until u-boot gets fixed
parent
046de13c
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
417 additions
and
3 deletions
+417
-3
u-boot-ezynq-binaries.bb
recipes-bsp/u-boot/u-boot-ezynq-binaries.bb
+103
-0
u-boot-ezynq.inc
recipes-bsp/u-boot/u-boot-ezynq.inc
+7
-3
u-boot.inc
recipes-bsp/u-boot/u-boot.inc
+307
-0
No files found.
recipes-bsp/u-boot/u-boot-ezynq-binaries.bb
0 → 100644
View file @
a84b719a
PROVIDES = "u-boot u-boot-ezynq"
LICENSE = "GPLv2+ & GPLv3"
LIC_FILES_CHKSUM = "file://${GITDIR_ezynq}/LICENSE;md5=891e49b3c2a8c133ffe7985e54245aff"
PACKAGE_ARCH = "${MACHINE_ARCH}"
PACKAGES = "u-boot-ezynq"
FILES_u-boot-ezynq = "/boot"
GITDIR_ezynq_dir= "git"
GITDIR_ezynq_label = "ezynq"
GITDIR_ezynq= "${WORKDIR}/${GITDIR_ezynq_dir}"
GITDIR_ezynq_bindir = "${GITDIR_ezynq}/images/elphel393"
S = "${GITDIR_ezynq}"
B = "${S}"
ELPHELGITHOST ??= "git.elphel.com"
SRC_URI_ezynq= "https://${ELPHELGITHOST}/Elphel/ezynq.git"
SRC_URI_ezynq_branch= "master"
##########################################################################################
# Defining u-boot.inc parameters
UBOOT_SUFFIX = "img"
UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_BINARY = "u-boot.${UBOOT_SUFFIX}"
UBOOT_SYMLINK = "u-boot-${MACHINE}.${UBOOT_SUFFIX}"
UBOOT_MAKE_TARGET = "all"
SPL_SUFFIX = "bin"
SPL_BINARY = "boot.${SPL_SUFFIX}"
SPL_IMAGE = "boot-${MACHINE}-${PV}-${PR}.${SPL_SUFFIX}"
SPL_SYMLINK = "boot-${MACHINE}.${SPL_SUFFIX}"
# Tasks
# partially from u-boot-ezynq-tasks.inc
# when updating from Jethro to Rocko 'cleandirs' is set for S
# So it happily nukes a freshly cloned u-boot repo, so:
# unsetting cleandirs flag:
python(){
d.setVarFlag('do_unpack','cleandirs', '')
}
##########################################################################################
# SRC_URI - Couldn't find how to deal with multiple git repos:
# 1. Tried and it didn't work: http://lists.linuxtogo.org/pipermail/openembedded-core/2011-October/010926.html
# 2. No *.bb examples found
# Overriding do_fetch:
do_fetch(){
echo "Fetching ezynq..."
if [ ! -d "${GITDIR_ezynq}/.git" ]; then
# if anything left after do_clean - delete it
if [ -d ${GITDIR_ezynq} ]; then
rm -r ${GITDIR_ezynq}
fi
git clone -b ${SRC_URI_ezynq_branch} ${SRC_URI_ezynq} ${GITDIR_ezynq}
cd ${GITDIR_ezynq}
git checkout ${SRCREV_ezynq}
cd ${WORKDIR}
echo "Cloning ezynq done."
else
echo "Skipped: ezynq is already cloned."
fi
}
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install(){
install -d ${D}/boot
install -m 644 ${GITDIR_ezynq_bindir}/boot.bin ${D}/boot/boot.bin
install -m 644 ${GITDIR_ezynq_bindir}/u-boot-dtb.img ${D}/boot/u-boot-dtb.img
}
inherit deploy
do_deploy(){
install -d ${DEPLOYDIR}
install -m 644 ${GITDIR_ezynq_bindir}/boot.bin ${DEPLOYDIR}/boot.bin
install -m 644 ${GITDIR_ezynq_bindir}/u-boot-dtb.img ${DEPLOYDIR}/u-boot-dtb.img
cd ${DEPLOYDIR}
for RLOC in ${PRODUCTION_ROOT_LOCATION}; do
if [ ! -d ${RLOC} ]; then
mkdir ${RLOC}
fi
if [ -f ${RLOC}/boot.bin ]; then
rm ${RLOC}/boot.bin
fi
cp boot.bin ${RLOC}/
if [ -f ${RLOC}/u-boot-dtb.img ]; then
rm ${RLOC}/u-boot-dtb.img
fi
cp u-boot-dtb.img ${RLOC}/u-boot-dtb.img
done
}
addtask deploy before do_build after do_compile
recipes-bsp/u-boot/u-boot-ezynq.inc
View file @
a84b719a
require
recipes
-
bsp
/
u
-
boot
/
u
-
boot
.
inc
require
u
-
boot
.
inc
DEPENDS
+=
"bc-native dtc-native"
DEPENDS
=
"bc-native dtc-native"
#require recipes-bsp/u-boot/u-boot.inc
#DEPENDS += " bc-native dtc-native"
LICENSE
=
"GPLv2+ & GPLv3"
LICENSE
=
"GPLv2+ & GPLv3"
LIC_FILES_CHKSUM
=
"file://${GITDIR_uboot}/README;md5=f0b2103a037ad81f10894cc74e3b6212 \
LIC_FILES_CHKSUM
=
"file://${GITDIR_uboot}/README;md5=f0b2103a037ad81f10894cc74e3b6212 \
...
@@ -59,9 +61,11 @@ SRCREV_ezynq= ""
...
@@ -59,9 +61,11 @@ SRCREV_ezynq= ""
#SRCREV_uboot= "2a0536fa48db1fc5332e3cd33b846d0da0c8bc1e"
#SRCREV_uboot= "2a0536fa48db1fc5332e3cd33b846d0da0c8bc1e"
#SRCREV_uboot= "fa85e826c16b9ce1ad302a57e9c4b24db0d8b930"
#SRCREV_uboot= "fa85e826c16b9ce1ad302a57e9c4b24db0d8b930"
SRCREV_uboot
=
"aeaec0e682f45b9e0c62c522fafea353931f73ed"
SRCREV_uboot
=
"aeaec0e682f45b9e0c62c522fafea353931f73ed"
#SRCREV_uboot= "8c5d4fd0ec222701598a27b26ab7265d4cee45a3"
#SRCREV_uboot= "0157013f4a4945bbdb70bb4d98d680e0845fd784"
#for u-boot-xlnx
#for u-boot-xlnx
#SRCREV_uboot= "01b1fea9b13b799a16efd743587dc861719e5212"
#SRCREV_uboot= "01b1fea9b13b799a16efd743587dc861719e5212"
PATCH_NAME
=
"ezynq.patch"
PATCH_NAME
=
"ezynq.patch"
include
u
-
boot
-
ezynq
-
tasks
.
inc
include
u
-
boot
-
ezynq
-
tasks
.
inc
\ No newline at end of file
recipes-bsp/u-boot/u-boot.inc
0 → 100644
View file @
a84b719a
SUMMARY
=
"Universal Boot Loader for embedded devices"
PROVIDES
=
"virtual/bootloader"
B
=
"${WORKDIR}/build"
PACKAGE_ARCH
=
"${MACHINE_ARCH}"
inherit
uboot
-
config
uboot
-
extlinux
-
config
uboot
-
sign
deploy
EXTRA_OEMAKE
=
'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" V=1'
EXTRA_OEMAKE
+=
'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
PACKAGECONFIG
??=
"openssl"
# u-boot will compile its own tools during the build, with specific
# configurations (aka when CONFIG_FIT_SIGNATURE is enabled) openssl is needed as
# a host build dependency.
PACKAGECONFIG
[
openssl
]
=
",,openssl-native"
# Allow setting an additional version string that will be picked up by the
# u-boot build system and appended to the u-boot version. If the .scmversion
# file already exists it will not be overwritten.
UBOOT_LOCALVERSION
?=
""
# Some versions of u-boot use .bin and others use .img. By default use .bin
# but enable individual recipes to change this value.
UBOOT_SUFFIX
??=
"bin"
UBOOT_IMAGE
?=
"u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_SYMLINK
?=
"u-boot-${MACHINE}.${UBOOT_SUFFIX}"
UBOOT_MAKE_TARGET
?=
"all"
# Output the ELF generated. Some platforms can use the ELF file and directly
# load it (JTAG booting, QEMU) additionally the ELF can be used for debugging
# purposes.
UBOOT_ELF
?=
""
UBOOT_ELF_SUFFIX
?=
"elf"
UBOOT_ELF_IMAGE
?=
"u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_ELF_SUFFIX}"
UBOOT_ELF_BINARY
?=
"u-boot.${UBOOT_ELF_SUFFIX}"
UBOOT_ELF_SYMLINK
?=
"u-boot-${MACHINE}.${UBOOT_ELF_SUFFIX}"
# Some versions of u-boot build an SPL (Second Program Loader) image that
# should be packaged along with the u-boot binary as well as placed in the
# deploy directory. For those versions they can set the following variables
# to allow packaging the SPL.
SPL_BINARY
?=
""
SPL_BINARYNAME
?=
"${@os.path.basename(d.getVar("
SPL_BINARY
"))}"
SPL_IMAGE
?=
"${SPL_BINARYNAME}-${MACHINE}-${PV}-${PR}"
SPL_SYMLINK
?=
"${SPL_BINARYNAME}-${MACHINE}"
# Additional environment variables or a script can be installed alongside
# u-boot to be used automatically on boot. This file, typically 'uEnv.txt'
# or 'boot.scr', should be packaged along with u-boot as well as placed in the
# deploy directory. Machine configurations needing one of these files should
# include it in the SRC_URI and set the UBOOT_ENV parameter.
UBOOT_ENV_SUFFIX
?=
"txt"
UBOOT_ENV
?=
""
UBOOT_ENV_BINARY
?=
"${UBOOT_ENV}.${UBOOT_ENV_SUFFIX}"
UBOOT_ENV_IMAGE
?=
"${UBOOT_ENV}-${MACHINE}-${PV}-${PR}.${UBOOT_ENV_SUFFIX}"
UBOOT_ENV_SYMLINK
?=
"${UBOOT_ENV}-${MACHINE}.${UBOOT_ENV_SUFFIX}"
# U-Boot EXTLINUX variables. U-Boot searches for /boot/extlinux/extlinux.conf
# to find EXTLINUX conf file.
UBOOT_EXTLINUX_INSTALL_DIR
?=
"/boot/extlinux"
UBOOT_EXTLINUX_CONF_NAME
?=
"extlinux.conf"
UBOOT_EXTLINUX_SYMLINK
?=
"${UBOOT_EXTLINUX_CONF_NAME}-${MACHINE}-${PR}"
do_compile
()
{
if
[
"${@bb.utils.filter('DISTRO_FEATURES', 'ld-is-gold', d)}"
];
then
sed
-
i
's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g'
$
{
S
}
/
config
.
mk
fi
unset
LDFLAGS
unset
CFLAGS
unset
CPPFLAGS
if
[
!
-
e
$
{
B
}
/.
scmversion
-
a
!
-
e
$
{
S
}
/.
scmversion
]
then
echo
$
{
UBOOT_LOCALVERSION
}
>
$
{
B
}
/.
scmversion
echo
$
{
UBOOT_LOCALVERSION
}
>
$
{
S
}
/.
scmversion
fi
if
[
-
n
"${UBOOT_CONFIG}"
]
then
unset
i
j
k
for
config
in
$
{
UBOOT_MACHINE
};
do
i
=
$
(
expr
$i
+
1
);
for
type
in
$
{
UBOOT_CONFIG
};
do
j
=
$
(
expr
$j
+
1
);
if
[
$j
-
eq
$i
]
then
oe_runmake
-
C
$
{
S
}
O
=
$
{
B
}
/
$
{
config
}
$
{
config
}
oe_runmake
-
C
$
{
S
}
O
=
$
{
B
}
/
$
{
config
}
$
{
UBOOT_MAKE_TARGET
}
for
binary
in
$
{
UBOOT_BINARIES
};
do
k
=
$
(
expr
$k
+
1
);
if
[
$k
-
eq
$i
];
then
cp
$
{
B
}
/
$
{
config
}
/
$
{
binary
}
$
{
B
}
/
$
{
config
}
/
u
-
boot
-
$
{
type
}
.
$
{
UBOOT_SUFFIX
}
fi
done
unset
k
fi
done
unset
j
done
unset
i
else
oe_runmake
-
C
$
{
S
}
O
=
$
{
B
}
$
{
UBOOT_MACHINE
}
oe_runmake
-
C
$
{
S
}
O
=
$
{
B
}
$
{
UBOOT_MAKE_TARGET
}
fi
}
do_install
()
{
if
[
-
n
"${UBOOT_CONFIG}"
]
then
for
config
in
$
{
UBOOT_MACHINE
};
do
i
=
$
(
expr
$i
+
1
);
for
type
in
$
{
UBOOT_CONFIG
};
do
j
=
$
(
expr
$j
+
1
);
if
[
$j
-
eq
$i
]
then
install
-
d
$
{
D
}
/
boot
install
-
m
644
$
{
B
}
/
$
{
config
}
/
u
-
boot
-
$
{
type
}
.
$
{
UBOOT_SUFFIX
}
$
{
D
}
/
boot
/
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_SUFFIX
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_SUFFIX
}
$
{
D
}
/
boot
/
$
{
UBOOT_BINARY
}
-
$
{
type
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_SUFFIX
}
$
{
D
}
/
boot
/
$
{
UBOOT_BINARY
}
fi
done
unset
j
done
unset
i
else
install
-
d
$
{
D
}
/
boot
install
-
m
644
$
{
B
}
/
$
{
UBOOT_BINARY
}
$
{
D
}
/
boot
/
$
{
UBOOT_IMAGE
}
ln
-
sf
$
{
UBOOT_IMAGE
}
$
{
D
}
/
boot
/
$
{
UBOOT_BINARY
}
fi
if
[
-
n
"${UBOOT_ELF}"
]
then
if
[
-
n
"${UBOOT_CONFIG}"
]
then
for
config
in
$
{
UBOOT_MACHINE
};
do
i
=
$
(
expr
$i
+
1
);
for
type
in
$
{
UBOOT_CONFIG
};
do
j
=
$
(
expr
$j
+
1
);
if
[
$j
-
eq
$i
]
then
install
-
m
644
$
{
B
}
/
$
{
config
}
/
$
{
UBOOT_ELF
}
$
{
D
}
/
boot
/
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_ELF_SUFFIX
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_ELF_SUFFIX
}
$
{
D
}
/
boot
/
$
{
UBOOT_BINARY
}
-
$
{
type
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_ELF_SUFFIX
}
$
{
D
}
/
boot
/
$
{
UBOOT_BINARY
}
fi
done
unset
j
done
unset
i
else
install
-
m
644
$
{
B
}
/
$
{
UBOOT_ELF
}
$
{
D
}
/
boot
/
$
{
UBOOT_ELF_IMAGE
}
ln
-
sf
$
{
UBOOT_ELF_IMAGE
}
$
{
D
}
/
boot
/
$
{
UBOOT_ELF_BINARY
}
fi
fi
if
[
-
e
$
{
WORKDIR
}
/
fw_env
.
config
]
;
then
install
-
d
$
{
D
}
$
{
sysconfdir
}
install
-
m
644
$
{
WORKDIR
}
/
fw_env
.
config
$
{
D
}
$
{
sysconfdir
}
/
fw_env
.
config
fi
if
[
-
n
"${SPL_BINARY}"
]
then
if
[
-
n
"${UBOOT_CONFIG}"
]
then
for
config
in
$
{
UBOOT_MACHINE
};
do
i
=
$
(
expr
$i
+
1
);
for
type
in
$
{
UBOOT_CONFIG
};
do
j
=
$
(
expr
$j
+
1
);
if
[
$j
-
eq
$i
]
then
install
-
m
644
$
{
B
}
/
$
{
config
}
/
$
{
SPL_BINARY
}
$
{
D
}
/
boot
/
$
{
SPL_IMAGE
}
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
ln
-
sf
$
{
SPL_IMAGE
}
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
$
{
D
}
/
boot
/
$
{
SPL_BINARYNAME
}
-
$
{
type
}
ln
-
sf
$
{
SPL_IMAGE
}
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
$
{
D
}
/
boot
/
$
{
SPL_BINARYNAME
}
fi
done
unset
j
done
unset
i
else
install
-
m
644
$
{
B
}
/
$
{
SPL_BINARY
}
$
{
D
}
/
boot
/
$
{
SPL_IMAGE
}
ln
-
sf
$
{
SPL_IMAGE
}
$
{
D
}
/
boot
/
$
{
SPL_BINARYNAME
}
fi
fi
if
[
-
n
"${UBOOT_ENV}"
]
then
install
-
m
644
$
{
WORKDIR
}
/
$
{
UBOOT_ENV_BINARY
}
$
{
D
}
/
boot
/
$
{
UBOOT_ENV_IMAGE
}
ln
-
sf
$
{
UBOOT_ENV_IMAGE
}
$
{
D
}
/
boot
/
$
{
UBOOT_ENV_BINARY
}
fi
if
[
"${UBOOT_EXTLINUX}"
=
"1"
]
then
install
-
Dm
0644
$
{
UBOOT_EXTLINUX_CONFIG
}
$
{
D
}
/
$
{
UBOOT_EXTLINUX_INSTALL_DIR
}
/
$
{
UBOOT_EXTLINUX_CONF_NAME
}
fi
}
FILES_
$
{
PN
}
=
"/boot ${sysconfdir}"
do_deploy
()
{
if
[
-
n
"${UBOOT_CONFIG}"
]
then
for
config
in
$
{
UBOOT_MACHINE
};
do
i
=
$
(
expr
$i
+
1
);
for
type
in
$
{
UBOOT_CONFIG
};
do
j
=
$
(
expr
$j
+
1
);
if
[
$j
-
eq
$i
]
then
install
-
d
$
{
DEPLOYDIR
}
install
-
m
644
$
{
B
}
/
$
{
config
}
/
u
-
boot
-
$
{
type
}
.
$
{
UBOOT_SUFFIX
}
$
{
DEPLOYDIR
}
/
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_SUFFIX
}
cd
$
{
DEPLOYDIR
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_SUFFIX
}
$
{
UBOOT_SYMLINK
}
-
$
{
type
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_SUFFIX
}
$
{
UBOOT_SYMLINK
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_SUFFIX
}
$
{
UBOOT_BINARY
}
-
$
{
type
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_SUFFIX
}
$
{
UBOOT_BINARY
}
fi
done
unset
j
done
unset
i
else
install
-
d
$
{
DEPLOYDIR
}
install
-
m
644
$
{
B
}
/
$
{
UBOOT_BINARY
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_IMAGE
}
cd
$
{
DEPLOYDIR
}
rm
-
f
$
{
UBOOT_BINARY
}
$
{
UBOOT_SYMLINK
}
ln
-
sf
$
{
UBOOT_IMAGE
}
$
{
UBOOT_SYMLINK
}
ln
-
sf
$
{
UBOOT_IMAGE
}
$
{
UBOOT_BINARY
}
fi
if
[
-
n
"${UBOOT_ELF}"
]
then
if
[
-
n
"${UBOOT_CONFIG}"
]
then
for
config
in
$
{
UBOOT_MACHINE
};
do
i
=
$
(
expr
$i
+
1
);
for
type
in
$
{
UBOOT_CONFIG
};
do
j
=
$
(
expr
$j
+
1
);
if
[
$j
-
eq
$i
]
then
install
-
m
644
$
{
B
}
/
$
{
config
}
/
$
{
UBOOT_ELF
}
$
{
DEPLOYDIR
}
/
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_ELF_SUFFIX
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_ELF_SUFFIX
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ELF_BINARY
}
-
$
{
type
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_ELF_SUFFIX
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ELF_BINARY
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_ELF_SUFFIX
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ELF_SYMLINK
}
-
$
{
type
}
ln
-
sf
u
-
boot
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
.
$
{
UBOOT_ELF_SUFFIX
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ELF_SYMLINK
}
fi
done
unset
j
done
unset
i
else
install
-
m
644
$
{
B
}
/
$
{
UBOOT_ELF
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ELF_IMAGE
}
ln
-
sf
$
{
UBOOT_ELF_IMAGE
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ELF_BINARY
}
ln
-
sf
$
{
UBOOT_ELF_IMAGE
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ELF_SYMLINK
}
fi
fi
if
[
-
n
"${SPL_BINARY}"
]
then
if
[
-
n
"${UBOOT_CONFIG}"
]
then
for
config
in
$
{
UBOOT_MACHINE
};
do
i
=
$
(
expr
$i
+
1
);
for
type
in
$
{
UBOOT_CONFIG
};
do
j
=
$
(
expr
$j
+
1
);
if
[
$j
-
eq
$i
]
then
install
-
m
644
$
{
B
}
/
$
{
config
}
/
$
{
SPL_BINARY
}
$
{
DEPLOYDIR
}
/
$
{
SPL_IMAGE
}
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
rm
-
f
$
{
DEPLOYDIR
}
/
$
{
SPL_BINARYNAME
}
$
{
DEPLOYDIR
}
/
$
{
SPL_SYMLINK
}
-
$
{
type
}
ln
-
sf
$
{
SPL_IMAGE
}
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
$
{
DEPLOYDIR
}
/
$
{
SPL_BINARYNAME
}
-
$
{
type
}
ln
-
sf
$
{
SPL_IMAGE
}
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
$
{
DEPLOYDIR
}
/
$
{
SPL_BINARYNAME
}
ln
-
sf
$
{
SPL_IMAGE
}
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
$
{
DEPLOYDIR
}
/
$
{
SPL_SYMLINK
}
-
$
{
type
}
ln
-
sf
$
{
SPL_IMAGE
}
-
$
{
type
}
-
$
{
PV
}
-
$
{
PR
}
$
{
DEPLOYDIR
}
/
$
{
SPL_SYMLINK
}
fi
done
unset
j
done
unset
i
else
install
-
m
644
$
{
B
}
/
$
{
SPL_BINARY
}
$
{
DEPLOYDIR
}
/
$
{
SPL_IMAGE
}
rm
-
f
$
{
DEPLOYDIR
}
/
$
{
SPL_BINARYNAME
}
$
{
DEPLOYDIR
}
/
$
{
SPL_SYMLINK
}
ln
-
sf
$
{
SPL_IMAGE
}
$
{
DEPLOYDIR
}
/
$
{
SPL_BINARYNAME
}
ln
-
sf
$
{
SPL_IMAGE
}
$
{
DEPLOYDIR
}
/
$
{
SPL_SYMLINK
}
fi
fi
if
[
-
n
"${UBOOT_ENV}"
]
then
install
-
m
644
$
{
WORKDIR
}
/
$
{
UBOOT_ENV_BINARY
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ENV_IMAGE
}
rm
-
f
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ENV_BINARY
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ENV_SYMLINK
}
ln
-
sf
$
{
UBOOT_ENV_IMAGE
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ENV_BINARY
}
ln
-
sf
$
{
UBOOT_ENV_IMAGE
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_ENV_SYMLINK
}
fi
if
[
"${UBOOT_EXTLINUX}"
=
"1"
]
then
install
-
m
644
$
{
UBOOT_EXTLINUX_CONFIG
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_EXTLINUX_SYMLINK
}
ln
-
sf
$
{
UBOOT_EXTLINUX_SYMLINK
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_EXTLINUX_CONF_NAME
}
-
$
{
MACHINE
}
ln
-
sf
$
{
UBOOT_EXTLINUX_SYMLINK
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_EXTLINUX_CONF_NAME
}
fi
}
addtask
deploy
before
do_build
after
do_compile
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment