Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
d1496984
Commit
d1496984
authored
May 18, 2016
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
1.+tmp pages 2.license from standard
parent
4c93e990
Changes
6
Expand all
Show whitespace changes
Inline
Side-by-side
Showing
6 changed files
with
173 additions
and
1502 deletions
+173
-1502
apps-web_1.0.bb
recipes-core/apps-web/apps-web_1.0.bb
+36
-0
controls.html
recipes-core/apps-web/files/controls.html
+33
-0
controls.js
recipes-core/apps-web/files/controls.js
+101
-0
core-image-elphel393.bb
recipes-core/images/core-image-elphel393.bb
+1
-0
LICENSE
recipes-core/init-tempmon/files/LICENSE
+0
-1499
init-tempmon_1.0.bb
recipes-core/init-tempmon/init-tempmon_1.0.bb
+2
-3
No files found.
recipes-core/apps-web/apps-web_1.0.bb
0 → 100644
View file @
d1496984
SUMMARY = "Temporary WebGUI pages"
DESCRIPTION = "Temporary WebGUI pages"
AUTHOR = "Elphel Inc."
HOMEPAGE = "http://www3.elphel.com/"
PRIORITY = "optional"
LICENSE = "AGPL-3.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/AGPL-3.0;md5=73f1eb20517c55bf9493b7dd6e480788"
SRCDATE = "20160518"
PV = "${SRCDATE}"
PR = "r0"
SRC_URI = "file://controls.html \
file://controls.js \
"
S = "${WORKDIR}/"
FILES_${PN} = "\
www/pages/* \
"
do_install_append() {
install -d ${D}/www/pages
install -m 0644 ${WORKDIR}/controls.html ${D}/www/pages
install -m 0644 ${WORKDIR}/controls.js ${D}/www/pages
}
PACKAGES = " apps-web"
#supress .debug generation
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
INHIBIT_PACKAGE_STRIP = "1"
\ No newline at end of file
recipes-core/apps-web/files/controls.html
0 → 100644
View file @
d1496984
<html>
<head>
<script
src=
"js/jquery-2.2.3.min.js"
></script>
<script
src=
"controls.js"
></script>
<style>
td
{
text-align
:
center
;
}
.exp
{
width
:
50px
;
text-align
:
right
;
padding
:
3px
;
}
.gain
{
width
:
30px
;
text-align
:
right
;
padding
:
3px
;
}
.r
{
border
:
2px
solid
rgba
(
200
,
100
,
100
,
1
);
}
.g
{
border
:
2px
solid
rgba
(
100
,
200
,
100
,
1
);
}
.b
{
border
:
2px
solid
rgba
(
100
,
100
,
200
,
1
);
}
</style>
</head>
<body
onload=
'init()'
>
</body>
</html>
\ No newline at end of file
recipes-core/apps-web/files/controls.js
0 → 100644
View file @
d1496984
$
(
function
(){
//init();
});
function
init
(){
var
t
=
$
(
"<table>"
).
html
(
"<tr><td id='pics'></td><td id='controls' valign='top'></td></tr>"
);
$
(
"body"
).
append
(
t
);
var
port
=
2323
;
for
(
i
=
0
;
i
<
4
;
i
++
){
var
url
=
"http://"
+
window
.
location
.
hostname
+
":"
+
(
port
+
i
)
+
"/noexif/img"
;
var
ref
=
"http://"
+
window
.
location
.
hostname
+
":"
+
(
port
+
i
)
+
"/noexif/mimg"
;
a
=
$
(
"<a>"
,{
href
:
ref
});
img
=
$
(
"<img>"
,{
id
:
"chn"
+
i
}).
css
({
width
:
"500px"
});
img
.
attr
(
"src"
,
url
);
img
.
attr
(
"src_init"
,
url
);
$
(
"#pics"
).
append
(
$
(
"<div>"
).
append
(
a
.
append
(
img
)));
img
.
load
(
function
(){
d
=
new
Date
();
n
=
d
.
getTime
();
this
.
src
=
$
(
this
).
attr
(
"src_init"
)
+
"&"
+
n
;
});
}
ct
=
$
(
"<table>"
);
tmpstr
=
"<tr><td>Chn</td><td>Exposure,ms</td><td>WB</td><td>Quality,%</td></tr>"
;
for
(
i
=
0
;
i
<
4
;
i
++
){
tmpstr
+=
"<tr>
\
<td>"
+
(
i
+
1
)
+
"</td>
\
<td><input type='text' id='exp"
+
i
+
"' class='exp' value='1' /></td>
\
<td>
\
<input type='text' id='r"
+
i
+
"' class='gain r' value='13' />
\
<input type='text' id='gr"
+
i
+
"' class='gain g' value='10' />
\
<input type='text' id='b"
+
i
+
"' class='gain b' value='12' />
\
<input type='text' id='gb"
+
i
+
"' class='gain g' value='10' />
\
</td>
\
<td><input type='text' id='q"
+
i
+
"' class='exp' value='80'/></td>
\
</tr>"
;
}
ct
.
html
(
tmpstr
);
$
(
"#controls"
).
append
(
ct
);
for
(
i
=
0
;
i
<
4
;
i
++
){
$
(
"#exp"
+
i
).
attr
(
"index"
,
i
);
$
(
"#exp"
+
i
).
change
(
function
(){
var
exp
=
Math
.
round
(
parseInt
(
$
(
this
).
val
())
*
1000
/
33.5
);
$
.
ajax
({
url
:
"imgsrv.py?expos="
+
exp
+
"&flip_x=0&flip_y=0&channel="
+
$
(
this
).
attr
(
"index"
),
complete
:
function
(){
console
.
log
(
"exposure set"
);}
});
});
$
(
"#q"
+
i
).
attr
(
"index"
,
i
);
$
(
"#q"
+
i
).
change
(
function
(){
$
.
ajax
({
url
:
"imgsrv.py?y_quality="
+
$
(
this
).
val
()
+
"&flip_x=0&flip_y=0&channel="
+
$
(
this
).
attr
(
"index"
),
complete
:
function
(){
console
.
log
(
"quality set"
);}
});
});
$
(
"#r"
+
i
).
attr
(
"index"
,
i
);
$
(
"#r"
+
i
).
change
(
function
(){
$
.
ajax
({
url
:
"imgsrv.py?gain_r="
+
$
(
this
).
val
()
+
"&flip_x=0&flip_y=0&channel="
+
$
(
this
).
attr
(
"index"
),
complete
:
function
(){
console
.
log
(
"gain_r set"
);}
});
});
$
(
"#gr"
+
i
).
attr
(
"index"
,
i
);
$
(
"#gr"
+
i
).
change
(
function
(){
$
.
ajax
({
url
:
"imgsrv.py?gain_gr="
+
$
(
this
).
val
()
+
"&flip_x=0&flip_y=0&channel="
+
$
(
this
).
attr
(
"index"
),
complete
:
function
(){
console
.
log
(
"gain_gr set"
);}
});
});
$
(
"#b"
+
i
).
attr
(
"index"
,
i
);
$
(
"#b"
+
i
).
change
(
function
(){
$
.
ajax
({
url
:
"imgsrv.py?gain_b="
+
$
(
this
).
val
()
+
"&flip_x=0&flip_y=0&channel="
+
$
(
this
).
attr
(
"index"
),
complete
:
function
(){
console
.
log
(
"gain_b set"
);}
});
});
$
(
"#gb"
+
i
).
attr
(
"index"
,
i
);
$
(
"#gb"
+
i
).
change
(
function
(){
$
.
ajax
({
url
:
"imgsrv.py?gain_gb="
+
$
(
this
).
val
()
+
"&flip_x=0&flip_y=0&channel="
+
$
(
this
).
attr
(
"index"
),
complete
:
function
(){
console
.
log
(
"gain_gb set"
);}
});
});
}
}
\ No newline at end of file
recipes-core/images/core-image-elphel393.bb
View file @
d1496984
...
...
@@ -33,6 +33,7 @@ IMAGE_INSTALL_append += " python-core \
libogg \
apps-camogm \
apps-imgsrv \
apps-web \
iw \
wpa-supplicant \
dhcp-client \
...
...
recipes-core/init-tempmon/files/LICENSE
deleted
100644 → 0
View file @
4c93e990
This diff is collapsed.
Click to expand it.
recipes-core/init-tempmon/init-tempmon_1.0.bb
View file @
d1496984
...
...
@@ -5,8 +5,8 @@ AUTHOR = "Elphel Inc."
HOMEPAGE = "http://www3.elphel.com/"
PRIORITY = "optional"
LICENSE = "GPL
v3
"
LIC_FILES_CHKSUM = "file://
LICENSE;beginline=21;endline=699;md5=ccd2fef7dee090f3b211c6677c3e34cc
"
LICENSE = "GPL
-3.0
"
LIC_FILES_CHKSUM = "file://
${COMMON_LICENSE_DIR}/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891
"
SRCDATE = "20160516"
...
...
@@ -15,7 +15,6 @@ PR = "r0"
SRC_URI = "file://init_tempmon \
file://init_tempmon.py \
file://LICENSE \
"
S = "${WORKDIR}/"
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment