Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
c5875bb4
Commit
c5875bb4
authored
Jul 07, 2016
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
overlay-sync
parent
55d7a9b2
Changes
4
Show whitespace changes
Inline
Side-by-side
Showing
4 changed files
with
98 additions
and
0 deletions
+98
-0
core-image-elphel393.bb
recipes-core/images/core-image-elphel393.bb
+1
-0
overlay_sync
recipes-core/overlay-sync/files/overlay_sync
+14
-0
overlay_syncd
recipes-core/overlay-sync/files/overlay_syncd
+39
-0
overlay-sync_1.0.bb
recipes-core/overlay-sync/overlay-sync_1.0.bb
+44
-0
No files found.
recipes-core/images/core-image-elphel393.bb
View file @
c5875bb4
...
...
@@ -46,6 +46,7 @@ IMAGE_INSTALL_append += " \
dhcpcd \
linux-firmware-rtl8192cu \
init-elphel393 \
overlay-sync \
init-tempmon \
ahci-blacklist \
udev-rules \
...
...
recipes-core/overlay-sync/files/overlay_sync
0 → 100644
View file @
c5875bb4
#!/bin/sh
rsync
-av
\
--exclude
'*.pyc'
\
--exclude
'.python-history*'
\
--exclude
'etc/udev-cache.tar.gz'
\
--exclude
'etc/udev'
\
--exclude
'media'
\
--exclude
'mnt'
\
--exclude
'run'
\
--exclude
'var'
\
/tmp/rootfs.rw/upperdir/ /tmp/rootfs.ro/
exit
0
recipes-core/overlay-sync/files/overlay_syncd
0 → 100644
View file @
c5875bb4
#!/bin/sh
PATH
=
/sbin:/bin:/usr/sbin:/usr/bin
NAME
=
overlay_syncd
DESC
=
"overlay sync"
case
"
$1
"
in
start
)
echo
-n
"Starting
$DESC
: "
echo
"
$NAME
:"
;;
stop
)
echo
-n
"Stopping
$DESC
: "
echo
"
$NAME
."
/sbin/overlay_sync
;;
restart
)
echo
-n
"Restarting
$DESC
: "
echo
"
$NAME
."
;;
status
)
echo
-n
"
$NAME
status:"
if
[
-f
/var/run/
$NAME
]
;
then
echo
-n
"Running"
else
echo
-n
"Not running"
fi
;;
sync
)
/sbin/overlay_sync
;;
*
)
N
=
/etc/init.d/
$NAME
echo
"Usage:
$N
{start|stop|restart|status|sync}"
>
&2
exit
1
;;
esac
exit
0
\ No newline at end of file
recipes-core/overlay-sync/overlay-sync_1.0.bb
0 → 100644
View file @
c5875bb4
SUMMARY = "Extra scripts for the Elphel 10393 board"
DESCRIPTION = "universal for overlayfs"
AUTHOR = "Elphel Inc."
HOMEPAGE = "http://www3.elphel.com/"
PRIORITY = "optional"
LICENSE = "GPL-3.0+"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891"
SRCDATE = "20160706"
PV = "${SRCDATE}"
PR = "r0"
SRC_URI = "file://overlay_sync \
file://overlay_syncd \
"
S = "${WORKDIR}/"
INITSCRIPT_NAME = "overlay_syncd"
INITSCRIPT_PARAMS = "start 99 2 3 4 5 . stop 99 0 1 6 ."
FILES_${PN} = "\
/etc/* \
/sbin/* \
"
#This needs to get the script into rc?.d/
inherit update-rc.d
do_install_append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/overlay_syncd ${D}${sysconfdir}/init.d
#install init script to /sbin
install -d ${D}${base_sbindir}
install -m 0755 ${WORKDIR}/overlay_sync ${D}${base_sbindir}
}
PACKAGES = " overlay-sync"
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment