Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
a9b5e6c7
Commit
a9b5e6c7
authored
May 22, 2019
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
removed looping through dtses
parent
56f23fad
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
with
20 additions
and
27 deletions
+20
-27
device-tree.bbappend
recipes-bsp/device-tree/device-tree.bbappend
+20
-27
No files found.
recipes-bsp/device-tree/device-tree.bbappend
View file @
a9b5e6c7
...
@@ -14,34 +14,27 @@ SRC_URI += "file://${MACHINE_DEVICETREE} \
...
@@ -14,34 +14,27 @@ SRC_URI += "file://${MACHINE_DEVICETREE} \
"
"
do_deploy(){
do_deploy(){
for DTS_FILE in ${S}/devicetree/*.dts; do
DTS_NAME=`basename ${DTS_FILE} | awk -F "." '{print $1}'`
DTS_NAME=`basename ${MACHINE_DEVICETREE} | awk -F "." '{print $1}'`
MACHINE_DTS_NAME=`basename ${MACHINE_DEVICETREE} | awk -F "." '{print $1}'`
echo "Copying ${DTS_NAME} device tree to production locations"
for RLOC in ${PRODUCTION_ROOT_LOCATION}; do
if test $MACHINE_DTS_NAME = $DTS_NAME; then
if [ ! -f ${B}/${DTS_NAME}_${RLOC}.dtb ]; then
echo "Copying ${MACHINE_DTS_NAME}"
echo "Warning: ${B}/${DTS_NAME}_${RLOC}.dtb is not available!"
for RLOC in ${PRODUCTION_ROOT_LOCATION}; do
continue
if [ ! -f ${B}/${DTS_NAME}_${RLOC}.dtb ]; then
fi
echo "Warning: ${B}/${DTS_NAME}_${RLOC}.dtb is not available!"
continue
install -d ${DEPLOY_DIR_IMAGE}
fi
install -m 0644 ${B}/${DTS_NAME}_${RLOC}.dtb ${DEPLOY_DIR_IMAGE}/${DTS_NAME}_${RLOC}.dtb
install -d ${DEPLOY_DIR_IMAGE}
if [ ! -d ${DEPLOY_DIR_IMAGE}/${RLOC} ]; then
install -m 0644 ${B}/${DTS_NAME}_${RLOC}.dtb ${DEPLOY_DIR_IMAGE}/${DTS_NAME}_${RLOC}.dtb
mkdir ${DEPLOY_DIR_IMAGE}/${RLOC}
echo "RootFS located in ${RLOC}"
if [ ! -d ${DEPLOY_DIR_IMAGE}/${RLOC} ]; then
mkdir ${DEPLOY_DIR_IMAGE}/${RLOC}
fi
if [ -f ${DEPLOY_DIR_IMAGE}/${RLOC}/${PRODUCTION_DEVICETREE} ]; then
rm ${DEPLOY_DIR_IMAGE}/${RLOC}/${PRODUCTION_DEVICETREE}
fi
cp ${DEPLOY_DIR_IMAGE}/${DTS_NAME}_${RLOC}.dtb ${DEPLOY_DIR_IMAGE}/${RLOC}/${PRODUCTION_DEVICETREE}
done
else
echo "Skipping ${DTS_NAME} (machine dts = ${MACHINE_DTS_NAME})"
fi
fi
if [ -f ${DEPLOY_DIR_IMAGE}/${RLOC}/${PRODUCTION_DEVICETREE} ]; then
rm ${DEPLOY_DIR_IMAGE}/${RLOC}/${PRODUCTION_DEVICETREE}
fi
cp ${DEPLOY_DIR_IMAGE}/${DTS_NAME}_${RLOC}.dtb ${DEPLOY_DIR_IMAGE}/${RLOC}/${PRODUCTION_DEVICETREE}
echo "Installed to ${DEPLOY_DIR_IMAGE}/${RLOC}/"
done
done
}
}
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment