Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
4e123d0c
Commit
4e123d0c
authored
Feb 20, 2016
by
Mikhail Karpenko
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
add AHCI driver patch
parent
c5237f99
Changes
4
Show whitespace changes
Inline
Side-by-side
Showing
4 changed files
with
51 additions
and
1 deletion
+51
-1
elphel393.dts
conf/machine/boards/elphel393/elphel393.dts
+8
-0
elphel393.cfg
recipes-kernel/linux/config/elphel393.cfg
+9
-1
drivers-ahci-elphel.patch
recipes-kernel/linux/linux-xlnx/drivers-ahci-elphel.patch
+33
-0
linux-xlnx_4.0.bbappend
recipes-kernel/linux/linux-xlnx_4.0.bbappend
+1
-0
No files found.
conf/machine/boards/elphel393/elphel393.dts
View file @
4e123d0c
...
...
@@ -448,6 +448,14 @@
interrupt-parent = <&ps7_scugic_0>;
interrupts = <0 7 4>;
} ;
elphel_ahci: elphel-ahci@80000000 {
compatible = "elphel,elphel-ahci";
interrupt-parent = <&ps7_scugic_0>;
interrupts = <0x0 0x1d 0x4>;
reg = <0x80000000 0x1000>;
clb_offs = <0x800>;
fb_offs = <0xc00>;
};
} ;
elphel393_pwr: elphel393-pwr@0 {
compatible = "elphel,elphel393-pwr-1.00";
...
...
recipes-kernel/linux/config/elphel393.cfg
View file @
4e123d0c
...
...
@@ -23,3 +23,11 @@ CONFIG_CMA_ALIGNMENT=8
#CONFIG_CMA_AREAS=7 #obsolete
CONFIG_MTD_TESTS=y
#
# AHCI driver related configs
#
CONFIG_ATA=y
CONFIG_ATA_VERBOSE_ERROR=y
CONFIG_SATA_AHCI_PLATFORM=y
CONFIG_AHCI_ELPHEL=M
recipes-kernel/linux/linux-xlnx/drivers-ahci-elphel.patch
0 → 100644
View file @
4e123d0c
diff --git a/drivers/ata/Kconfig b/drivers/ata/Kconfig
index 5f60155..5d93116 100644
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
@@ -157,6 +157,16 @@ config AHCI_XGENE
help
This option enables support for APM X-Gene SoC SATA host controller.
+config AHCI_ELPHEL
+ tristate "Elphel AHCI SATA driver support for elphel393 camera series"
+ depends on ARM
+ default m if ARM
+ help
+ This option enables support for Elphel AHCI SATA controller in elphel393
+ series cameras.
+
+ If unsure, say N.
+
config SATA_FSL
tristate "Freescale 3.0Gbps SATA support"
depends on FSL_SOC
diff --git a/drivers/ata/Makefile b/drivers/ata/Makefile
index ae41107..212dfed 100644
--- a/drivers/ata/Makefile
+++ b/drivers/ata/Makefile
@@ -5,6 +5,7 @@ obj-$(CONFIG_ATA) += libata.o
obj-$(CONFIG_SATA_AHCI) += ahci.o libahci.o
obj-$(CONFIG_SATA_ACARD_AHCI) += acard-ahci.o libahci.o
obj-$(CONFIG_SATA_AHCI_PLATFORM) += ahci_platform.o libahci.o libahci_platform.o
+obj-$(CONFIG_AHCI_ELPHEL) += ahci_elphel.o libahci.o libahci_platform.o
obj-$(CONFIG_SATA_FSL) += sata_fsl.o
obj-$(CONFIG_SATA_INIC162X) += sata_inic162x.o
obj-$(CONFIG_SATA_SIL24) += sata_sil24.o
recipes-kernel/linux/linux-xlnx_4.0.bbappend
View file @
4e123d0c
...
...
@@ -6,6 +6,7 @@ SRC_URI_append += " file://xilinx_emacps.c.patch"
SRC_URI_append += " file://xilinx_uartps.c.patch"
SRC_URI_append += " file://si5338_vsc330x.patch"
SRC_URI_append += " file://drivers-elphel.patch"
SRC_URI_append += " file://drivers-ahci-elphel.patch"
SRC_URI_append += " file://${MACHINE}.scc"
KERNEL_FEATURES_append = " ${MACHINE}.scc"
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment