Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Submit feedback
Contribute to GitLab
Sign in
Toggle navigation
M
meta-elphel393
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Commits
Open sidebar
Elphel
meta-elphel393
Commits
1aeb6d8c
Commit
1aeb6d8c
authored
Jul 21, 2016
by
Oleg Dzhimiev
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
PE_PV-PR
parent
3fef028f
Changes
2
Show whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
18 additions
and
8 deletions
+18
-8
elphel-misc.bbclass
classes/elphel-misc.bbclass
+15
-6
init-elphel393_1.0.bb
recipes-core/init-elphel393/init-elphel393_1.0.bb
+3
-2
No files found.
classes/elphel-misc.bbclass
View file @
1aeb6d8c
# Well
# returns string - based on file
def version_update(path,file):
with open(path+'/'+file, 'r') as content_file:
content = content_file.read()
content = content.strip(' \t\n\r')
return content
def version_update(path,file,evr):
for line in open(path+'/'+file):
line = line.strip()
if (line[0]!="#"):
break
arr = line.split('.')
try:
arr[evr]
except IndexError:
if (evr==1): res = 0
if (evr==2): res = revision_update(path,file)
else:
res = arr[evr]
return res
def revision_update(path,file):
import subprocess
...
...
recipes-core/init-elphel393/init-elphel393_1.0.bb
View file @
1aeb6d8c
...
...
@@ -20,8 +20,9 @@ SRCDATE = "20131202"
inherit elphel-misc
VPATH = "${TOPDIR}/../../fpga-elphel/x393"
VFILE = "VERSION"
PV = "${@version_update ('${VPATH}','${VFILE}')}"
PR = "${@revision_update('${VPATH}','${VFILE}')}"
PE = "${@version_update('${VPATH}','${VFILE}',0)}"
PV = "${@version_update('${VPATH}','${VFILE}',1)}"
PR = "${@version_update('${VPATH}','${VFILE}',2)}"
RDEPENDS_${PN} += "\
python-core \
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment